Change FOG form Dhcp to Static IP



  • Hi Everyone,
    I just started using FOG and with the help of some videos was able to get it setup and running…Unfortunately I know nada about the system. I somehow have it setup the get and ip address from my win2k3 server. How do I configure it to use a static ip address?

    Thanks…



  • I love this actually working with the device instead of just punching buttons…reminds me of the good old days of DOS. I look forward to working with everyone.

    btw…after all of that I decided to put it on a different box. I would have loved to troubleshot why it wasn’t working correctly, but a deadline was looming so I killed it and reimaged the workstations again…took far less time than the first.


  • Developer

    Awesome, glad you got it going!



  • That didn’t work…a little more searching I found:

    auto eth0 iface eth0 inet static . . . dns-nameservers 8.8.8.8 8.8.4.4

    An edit, save, restart later it works!

    Thanks for the help :)



  • first part went without a hitch…Thank you.

    When I bring up the resolv.conf file it is populated with two comment lines:

    Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)

    DO NOT EDIT THIS FILE BY HAND – YOUR CHANGE WILL BE OVERWRITTEN

    I’ll remove the dhcp-client and restart the networking and see what happens…


  • Developer

    That is the server edition not the desktop edition, which is what I previously posted. Yes you will need to do it via the command line.

    try this

    sudo vi /etc/network/interfaces

    For the primary interface, which is usually eth0, you will see these lines:

    auto eth0
    iface eth0 inet dhcp

    edit it to something similar to this

    auto eth0
    iface eth0 inet static
    address 192.168.1.100
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.1.1

    save and exit.

    sudo vi /etc/resolv.conf

    On the line ‘name server xxx.xxx.xxx.xxx’ replace the x with the IP of your name server. (You can do ifconfig /all to find out what they are) save and exit.

    You need to also remove the dhcp client for this to stick

    sudo apt-get remove dhcp-client

    now restart networking

    sudo /etc/init.d/networking restart



  • a command line.


  • Developer

    after you log in are you presented with a graphical interface or are you presented with a command line?



  • It is a bit more complicated than that I am afraid…the only thing that comes up is a prompt on the server. I can log into it but that is about it. I’m thinking it will involve some sort of sudo editing of a file somewhere.

    btw the video I followed to get it installed is here: [media=youtube]UqJ3GicmGG0[/media]


  • Developer

    I’m going to assume this is a desktop install and not the LTS install.

    Click the “Dash Home” icon, in the text box at the top type “Network” and select the first icon in the list displayed as “Network”. Select Wired and click Options. Select the “IPV4 Settings” tab and change the method from Automatic to Manual, Add, and supply the server with a proper IP address and information. Click Save. Your connection will reconnect.



  • [B]linux ubuntu 12.04,12.10 [/B]


  • Developer

    what linux version did you use to install fog with?


Log in to reply
 

324
Online

38729
Users

10555
Topics

99937
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.