Windows 8, sysprep, and Active Directory Based Activation

  • Moderator

    I’m trying to move forward with Windows 8 on our tablets. I have done a fresh install and joined to a domain that is Active Directory Based Activation enabled. Windows and Office 2013 activate against the directory, Office 2013 creates a unique CMID, but Windows does not. I can’t seem to get a CMID at all. Running slmgr.vbs /dlv does not show a CMID at all.

    I have also tried installing, going straight into audit mode, and running sysprep /oobe /generalize, rebooted and joined to domain for activation, still no CMID.

    What am I missing about this?

  • The only thing I can think of then is that maybe you don’t have the generic KMS key on your windows 8 host. Try changing it:-


  • I see. We were already running KMS for windows 7 /office 2010, just updated KMS for Windows 8 and office 2013 and didn’t have to worry about the count (already reached in Windows 7).

    An update to the schema scares admins.

  • Moderator

    The new Active Directory Based Activation (ADBA). It uses the same KMS host key and Generic Volume License Key that KMS uses, but it activates Windows 8 and Server 2012 and Office 2013 when you join them to the domain, rather than having to manage a KMS host. It also has no minimum host count requirements, so the first host out of the box is fully activated when it joins AD. If you remove a host from AD, it deactivates all the products that are activated against the domain.

    It requires 2003 functional level on the forest and domain, and either a Windows 8 client running remote server admin tools (RSAT) and Volume Activation Management Tool (VAMT) or a Windows 2012 server. You have to adprep the forest to add the ability to have Active Directory Based Activiation Objects in the schema, but you don’t have to be at 2012 functional levels.

  • To be honest, I don’t understand what you mean by AD activation. Its only MAK or KMS? We use KMS successfully with Windows 8.

    AD activation new in windows 8?

  • Moderator

    What if I install Windows 8, boot to audit mode at the welcome screen, then just select generalize and oobe at the sysprep prompt. No unattend.xml, no skip rearm settings etc.

    I have also tried rearming after the oobe runs, but I don’t get a CMID there either, even after a reboot. I’m just not sure that a CMID is generated for Windows 8 activated against AD and I am looking for confirmation of someone that has does a Windows 8 sysprep image and used AD activation and has a CMID when they run slmgr /dlv

  • You need to make sure windows 8 rearms. Remove skiprearm=1 from your unattend xml or rearm after imaging with a script to get an unique CMID (slmgr.vbs /rearm)