Change hostname early setting



  • There is a setting called CHANGE_HOSTNAME_EARLY, which I understand is supposed to change the hostname right after imaging is complete. I have it set to 1, but when I image my machines they always show “Changing hostname… [SKIPPED]”

    I’m using Windows XP in a non-domain environment, is that not supported?



  • Try one of the newer kernel’s. I think the older kernels don’t support the change right after imaging.


  • Developer

    [I]“Tried setting it to 0 and 1, still says SKIPPED when imaging finishes.”[/I]
    Here the problem is that the fog script doesn’t find the variable $hostname or is empty, and when invokes the function changeHostname, the condition:
    if [-n hostname]…

    is false. And doesn’t makes the changes in the windows registry.

    To be sure that the variable is sent, you can make this:
    [LIST=1]
    []send a deploy task.
    [
    ]in the FOG server must be a file in /tftfboot/pxelinux.cfg/01-XX-XX-XX-XX-XX-XX . XX-XX-XX-XX-XX-XX is the client MAC address.
    [*]The file looks like this:
    [/LIST]
    [CODE]# Created by FOG Imaging System,
    DEFAULT fog
    LABEL fog
    kernel fog/kernel/bzImage
    append initrd=fog/images/init.gz root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=
    type=down img=aula-bz-ciencias-mug002-docencia mc=yes port=63208 storageip=192.xxx.xxx.xxx storage=192.xxx.xxx.xxx:/images/ mac=XX:XX:XX:XX:XX:XX ftp=192.xxx.xxx.xxx web=192.xxx.xxx.xxx/fog/ osid=1 imgType=n shutdown= loglevel=4
    fdrive= chkdsk=0 hostname=UXXXXXX[/CODE]

    If the hostname variable value is null or empty, then the fog script skips the hostname change.



  • Ah, it just occurred to me that when you sysprep, there is no hostname until the first boot. Could that be why?

    Any way to use this feature along with sysprep?

    I’m using FOG 0.32 with single partition+resizable images.


  • Developer

    What version of FOG are you using?
    Image partitions?
    The error apears when the hostname variable not exists.



  • It’s at Other Information -> FOG Settings -> scroll down to General settings

    Tried setting it to 0 and 1, still says SKIPPED when imaging finishes.



  • Where are you finding this setting at? I can check 1 of my 6 environments that it is working at and see what my setting it at.


Log in to reply
 

430
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.