• I am trying to do a new install of Fog on Ubuntu 11.04 (32 bit). I keep getting a php-gettext failed message when it goes through the checking package process during the installation of Fog. Once it hits that php-gettext failed, the installation process stops. I tried version 0.32 and 0.31 both come up with the same issue. Doing some research I found it seems to a common issue installing Fog on CentOS but nothing about Ubuntu. I hoping someone may have some words of wisdom on how I can correct this and complete the install of Fog.

  • I fixed my issue by upgrading to Ubuntu 11.10. After that the Fog installer was able to finish without the php-gettext holding up the process. Thank you to those who responded.

  • Hello 🙂

    Try this (all commands with sudo or as root)

    log on, sudo the delete the file .fogsettings on /var/fog/.fogsettings.
    after, apt-get update
    then, run the installfrog again.

    If you not find the file, try to apt-get update before the install. If fails:

    apt-get clean
    apt-get update

  • Good though and I tried manually installing it but when the Fog installer get to the php-gettext package it fails still.

  • What about trying to install php-gettext manually?

    [CODE]sudo apt-get install php-gettext[/CODE]

  • Yes I put sudo ./installfog.sh No it not a patronizing question. As a tech I know you need to ask those questions. Thank you for the reply and suggestion.

  • I know this is a really stupid and possibly patronizing question, but are you putting sudo before invoking the command? Same thing happened to me until I hit sudo