Refuse to boot on my DHCP



  • Hello,
    I have just finished the install of FOG on my Intranet (Debian 5), and I’ve configured My DHCP (windows 2k8 r2), so in the option 66 there is “192.168.10.250” and there is “pxelinux.0” in the option 67.
    I can from my pc ping the fog server, and my DHCP work well. There is just my principal switch (cisco 3550) between the PC who need to boot in PXE and the fog server and DHCP server.


  • Developer

    Leon, are you still having issues?

    From reading your statement I have gathered that you want to save your images from your FOG server on a network space, is this correct?

    I know that FOG is going to need access to this folder with read and write permissions, I would first start with checking there and trying to make a public space where it will not be affected but network policies.

    We use a Novell Network here and I run into problems with permissions all the time.

    However I am not familiar with adding a space for the FOG server to save an image to, in my FOG server there is a drop down box where I can select “default” and possibly a node if I had installed one. I don’t know what is involved with locating the space on the network and adding it to the drop down list.

    I would also install the Samba service of Ubuntu to help alleviate some of the problems your going to run into using a Linux box in Windows environment.


  • Developer

    I’m sorry My expertise is at a limit here I’m still new, i’m glad we got your FOG to where it boots but I’m going to bow out now and let someone familiar with NAS step in good luck Leon!



  • Hello again !
    Now it work, I can make image from PC, upload and deploy them ! But just a little problem, when I mount my NAS, the directory got a new owner (owner =“244”) and I can’t change this not even when i’m lof in root. So fog can not write on the directory. Is it normal ? How can I use my nas for save my ghost ? I follow lot of tuto but lot of them don’t work, i will try with fog wiki. (http://www.fogproject.org/wiki/index.php?title=FOGUserGuide#Separate_NFS_Server, is that a good tutorial ?)
    Cordially, Léon


  • Developer

    You say it worked? what was the output you received after entering the commands?

    If you receive “Received XXXX bytes in X.X seconds…” or something similar then TFTP is in fact running and is accessible, and this probably falls under the same issue I ran into.

    Try re-installing fog WITHOUT specifying a DNS, or DHCP server, after successful install, please use this wiki and install the dnsmasq for proxyDHCP. Now try booting PXE, what do you get?
    Wiki is Here ->http://www.fogproject.org/wiki/index.php?title=Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server



  • Hello i do what you say and that work, so I’ve got news !
    That still don’t work on my pc who is on the same vlan of the server but on the other pc of the vlan and on the other vlan it’s work correctly ! And i’ve got problem with fog, because every service work but there is lot of error ! is it normal ?


  • Developer

    it’s good that ping is working, lets try to see if tftp service is running

    from windows open a command prompt and type

    
    tftp x.x.x.x get pxelinux.0
    
    

    where x.x.x.x is the IP address of your fog server.

    linux command from a terminal

    
    tftp -v x.x.x.x -c get pxelinux.0
    
    

    again where x.x.x.x is the IP address of your fog server.

    After typing the commands and pressing enter what happens?



  • Hello i’m running fog on a debian 5(VM on my vmware esxi 5.1), when i boot my work station on pxe there is “No DHCP and proxyDHCP where found”.
    My network got 10 Vlan, I’ve configured only vlan0010 for the DHCP(w2k8 r2) with the option 66 and 77, i follow all the tutorial but nothing work.
    Between my server and my workstation there is a switch (cisco 3550).
    If you need more information i’m here today !

    PS: Ping work between my workstation/DHCP/FOGserver


  • Developer

    What version of Linux are you running? I dropped back to Ubuntu 10.04 to prevent having to do any of that, plus it was part of the troubleshooting steps Chad wanted me to go threw :)

    I was able to run commands on Linux and Windows to talk to my tftp server so I knew it wasn’t the service being an issue.

    This just proves we need your input, Ferrari, so we can help you :)



  • Jaymes, if it’s any consolation, I too had the same issue, but running [B]sudo restart tftpd-hpa [/B]fixed the issue.

    So all I needed to do was change /etc/rc.local and add
    /bin/sleep30 && /etc/init.d/tftpd-hpa restart


  • Developer

    I second what Icarus has said, if you tell us the error you are receiving, we can walk you through some troubleshooting steps.

    When you boot your workstation and PXE boot, what do you see?

    I just fixed a problem here with my FOG server where it was not playing nicely with my tftpboot, only part of the packet got received and was throwing the “PXE-E32 TFTP Open Time Out” error. Installing the proxyDHCP service solved this for me.

    http://fogproject.org/forum/threads/tftp-problems.4163/



  • Ok so what happens on boot?

    Does it boot to network and get a DHCP address but then fail to do anything further?
    Do you get an error message?

    Or does the machine just not boot to network at all without even getting DHCP?

    Do you get the error PXE-32: TFTP open timeout ?


Log in to reply
 

352
Online

38746
Users

10569
Topics

100051
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.