Problem PXE booting Trinity Rescue Kit through FOG, no problem w/ just TRK



  • Hi all. Cross posting this from the TRK forums, since it could be a FOG problem as well.

    I just discovered FOG and TRK last week and I think they’re great!

    I want to use TRK as our network bootable recovery disk. I point DHCP option 67 to TRK’s pxelinux.0 and that works fine. But I want to incorporate TRK into my existing FOG setup. That’s where the problem comes in.

    When I choose TRK from the FOG menu, the TRK menu comes up, but the background isn’t loaded. Choosing the first option just restarts the Autoboot timer, any other option does nothing.

    default tftp folder is /srv/tftp

    [CODE]My folders:
    /srv
    -/tftp
    -FOG’s pxelinux.0
    -/FOG’s pxelinux.cfg
    -/trkfiles
    -TRK’s pxelinux.cfg and everything else for TRK

    FOG’s pxelinux.cfg entry for TRK:

    LABEL Trinity
    MENU LABEL Trinity
    MENU PASSWORD ******
    KERNEL vesamenu.c32
    APPEND trkfiles/pxelinux.cfg/default

    TRK’s pxelinux.cfg/default is unedited[/CODE]

    TRK 3.4 build 372
    Windows DHCP
    FOG server is a Debian 6 VM in WMWare
    Target computers are another VM and a physical client workstation. This happens on both targets.

    Like I said, I can pxe boot TRK fine by itself. I can also boot a WinPE iso through FOG. I tried booting a TRK iso through FOG and had a different issue. I feel like I’m really close, but I’ve been hammering at this particular issue for 2 days and I’m stuck. I’d like help instead of wasting too much more time being stubborn. Any ideas? Any more info I can provide?

    Thanks for your time!



  • TRK booting NOT on an iso requires NFS to send files across the network. After TRK boots, the startup script copies files over NFS. keep in mind that NFS is not like samba and requires a full path. Thats what tripped me up.


  • Moderator

    I can get the iso to load, but when I choose an option from the TRK menu, it tries to load TRK from CD and fails.



  • Hey, thanks for the reply!

    I want TRK to be an option in my main menu. When I choose TRK, it will load TRK and put me in the TRK menu, just like booting TRK.

    I played with the ISO option in that specific guide for a few days this week. Like I said, I can boot WinPE, but I have a different issue with TRK.

    When I boot TRK as an ISO, I get the TRK menu, except the background is missing and choosing any options has no affect, except when choosing the first option, default, the Autoboot timer resets. Do you have any ideas about that? Like I said, I’d prefer being able to boot the TRK kernel from the FOG menu, but I would be happy being able to boot the ISO properly.

    I’m pretty new to Linux. Not sure if I said that right.

    So as far as my first issue: Can you see anything wrong with my code for the menu option? vesamenu.c32 IS the correct kernel?


  • Moderator

    Are you wanting to execute TRK from the main menu, or select TRK from the main menu and get a TRK sub menu with a list of options?

    Good info in this thread, especially near the end. [url]http://fogproject.org/forum/threads/how-to-modify-the-pxe-boot-menu-to-allow-the-booting-of-iso-files.154/[/url]


Log in to reply
 

426
Online

38951
Users

10701
Topics

101530
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.