TFTP Problems


  • Developer

    Let me start by saying I’m still very new at this.

    Anyway I have installed and configured my FOG server, I had it happily talking with my computers until I edited the DHCP server to add the line 66 and 67 to it to point to my fog server. Before I was able to get it to the fog server by letting it first get a DHCP address and then disconnect it from the network to the DHCP (only still being connected to the FOG Network) and I could boot my pxe menu.

    Today, I am not able to get my PXE menu, It grabs a DHCP address and it looks to the TFTP and it only times out. I have tried a stop and restart of the TFTP service, I have tried my previous methods (disconnect form network stay only connected to fog) but this does not seem to be working today.

    I am at a loss and I need assistance with getting my fog server communicating with my workstations again.

    I have followed the Wiki and reset my fog password, I have defined and edited the /var/www/fog/commons/config.php and reloaded it after first editing the password in the fog manager, I have tried start the DHCP service and running only in my little workroom network but even this is not working today :( Please help!

    [url]http://www.fogproject.org/wiki/index.php/Unable_to_connect_to_tftp_server[/url] - Told me to change the passwords.

    but I am also looking at [url]http://www.fogproject.org/wiki/index.php/Tftp_timeout[/url]
    but with the command I get a return
    [code]
    Connected to 10.8.22.3 (10.8.22.3), port 69
    getting from 10.8.22.3:pxelinux.0 to pxelinux.0 [netascii]
    Received 16967 bytes in 0.0 seconds [4349119 bit/s][/code]

    so from my understanding the TFTP is doing what it’s suppose to but the pxelinux.0 is not?


  • Developer

    Well i didn’t find a hub, I had a linksys wrt54g someplace that had ddwrt on it but I must have loaned it to someone because I can’t for the life of me find it. So I never will know what it was that is being stopped but I believe it’s similar to your situation that you described where a chunk of it is received but the rest is not.

    I have installed proxyDHCP and it seems to be happily working on 10.04 LTS.
    Now I can boot to my pxelinux.0!!!

    I appreciate all your help with this and your time, I’m going to be using it this summer and hopefully set up a few nodes in a few other buildings if all goes according to plan, so far it’s not been that bad of an experience just a typical Linux install lol.


  • Developer

    I will see what I can find.


  • Moderator

    If you can replace the switch with a good old HUB, you might have some luck.


  • Developer

    my switch does not allow port mirroring (Asus GX-D1081), the procurve more than likely does, but here is a number of MDFs plugged in and I’m not exactly sure which one leased to my office.

    I will install proxyDHCP tomorrow and see how it goes with 10.04.


  • Moderator

    Did you mirror the port on the switch so you can see it’s packets? Whatever port the pxe client is connected to needs to be mirrored to the port your monitoring workstation is connected.


  • Developer

    Alright, I have captured a set of packets from the time I began my Pxe boot till the time I got the error PXE-E32 TFTP open timeout.

    but I don’t actually see the host’s ip address or mac address in the set of information, is this a problem.

    What set of filters would you recommend, I do not see anything being transferred on TFTP.


  • Moderator

    When I was investigating mine, I started recording, tried to pxeboot and waited for error, then stopped recording. I went through several filters at different times to make sure the pxe boot was getting the correct next server name and bootfile name from dhcp. Then I filtered on tftp, or just everything matching the IP address the client got from DHCP.

    You can key in on the tftp problems, and see if it’s making a request for the pxelinux.0 file and getting all the chunks. In my case, it requested and got chunk 1, but then failed to get the rest of the chunks until I implemented proxyDHCP.


  • Developer

    What port do you recommend I watch? port 69 is the TFTP port correct?

    I’m willing to try the proxyDHCP again after I do the wireshark, i’d really like to figure out what the underlying issue is an try to eliminate it.


  • Moderator

    At this point, I would normally through a tech workstation on that switch, mirror/monitor a port, wireshark and see what is happening between the FOG server and the client.

    If you are not able to do that, then go ahead and proceed with setting up proxyDHCP according to the wiki article.


  • Developer

    Shameless bump still need help please :(


  • Developer

    yeah every test I have ran up to this point has been within my office on the same switch as the FOG server, and the switch I am using is an Asus GX-D1081.

    I agree our network seems a bit odd, but I was neither the person that designed or set it up so it is out of my control, I merely make sure all the components in this building work, and make the teachers happy :)


  • Moderator

    Your network configuration seems unusual to me. I don’t know if it has any thing to do with the problems you’re experiencing, but I don’t have a good feeling about it. It could be my lack of experience with advanced networking, or there could be something not quite right about your subnetting. We’ll ignore that for now though.

    Are you able to connect a PXE boot client to the same switch as the FOG server? I don’t mean just the FOG server and the client, it should be on your network. I just want the client and the server to both be on the same switch for the moment.


  • Developer

    My network is divided into VLANS, each building is 10.x.1.1 where x is 1-10 and 1-10 is the building designated to that ip scope, they all use the same subnet mask and dns/dhcp information, the only change is the ip addresses the buildings serve.


  • Moderator

    With a subnet mask fo 255.255.0.0, all of your 10.8.x.x addresses are logically in the same subnet. I’m assuming you don’t have your network subdivided into VLAN’s and subnets, you just serve DHCP for 10.8.10.1 to 10.8.15.255, and non-DHCP clients are statically assigned an address from outside that range. Is this correct?


  • Developer

    yes they are in the same subnet mask, 255.255.0.0 They are in the same Scope but not the same range per say, our DHCP range 10.8.10.1-10.8.15.255 but the server is at 10.8.22.3 this should not be a problem though.

    Is this what you want? or do you want something from the linux box?

    [url="/_imported_xf_attachments/0/287_dhcp.jpg?:"]dhcp.jpg[/url]


  • Moderator

    Can you provide a screenshot of your dhcp settings? Are the clients in the same subnet/scope as the FOG server?


  • Developer

    Wow, sorry for my absence here, I ran into some trouble with the monitors we use here and the video card and linux. While I had absolutely no problems with 12.04 and graphics cards. I ended up taking the server home to install Ubuntu and use a real monitor :).

    Anyway long story short it took a lot of fiddling but I have done what you have asked, I now have Ubuntu 10.04 LTS, set static IP, I updated, upgraded (from terminal), got Gnome, installed FOG again.

    Boot to PXE get PXE-E32: TFTP open timeout.

    BUT if i use gPXE and specify the information I CAN get to my pxe menu, so what am I not doing right?

    if I use gPXE I have to catch it before it autoboots with Ctrl+b and run the config I speficy the DHCP 10.8.1.1, DNS 10.1.2.6, image as pxelinux.0, netmask 255.255.0.0, Gateway 10.8.255.254, next-server 10.8.22.3 I crtl+x and type autoboot and boom FOG PXE

    so, what have I boogered up?


  • Developer

    Thanks chad I will do just that, I am downloading the 10.04 LTS as I type this, it is almost 3:00 here and I go home in half hour, but I have all next week to myself, I will bump this thread when I have installed Ubuntu 10.04 LTS and followed your instructions!


  • Moderator

    Let’s get back to a stable and known state with the FOG server. You’ve changed passwords, tried proxyDHCP, and made other changes to the server, so let’s get back to solid ground.

    I suggest you take a step back and try 10.04 Server LTS. The 12.x versions introduce the TFTP problem that, easy enough to fix, makes it harder to get started, and that’s not something for someone new to FOG/Linux. Also, I’m not sure, but I prefer to use a Server distribution rather that a desktop.

    The first thing you should do after installing the base OS is to update apt, and then upgrade the system. This is not a release-upgrade, just a regular upgrade to make sure you have the latest version of all the base OS packages installed and that you are pulling packages from an updated apt when you run the FOG install script.

    So:
    [LIST]
    []Install base OS. !!! DO [B]NOT[/B] MAKE A USER NAMED FOG !!! use bob, ted, fred, billy, sue, whatever, but not fog
    [
    ]Set IP static with correct subnet mask and gateway
    []sudo apt-get update
    [
    ]sudo apt-get upgrade
    [][Optional]: grab a desktop, such as Gnome with: sudo apt-get gnome-desktop-environment
    [
    ]go get coffee
    []Download and extract the FOG installer
    [
    ]Run FOG installer, tell it not to use DHCP, no DNS address, no router address
    []use a blank mySQL password for now. (if you want to secure it we’ll walk through that later)
    [
    ]Make sure your non-FOG DHCP server is pointing to the correct IP and filename (pxelinux.0 <— that’s a ZERO)
    [/LIST]

    At this point, you don’t need to worry about any config files, we should be ready to pxeboot our first machine

    So, Try to pxe boot a host. What do you get?


Log in to reply
 

366
Online

38984
Users

10712
Topics

101689
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.