FOG unable to PXE boot beyond the VLAN/subnet that the server is on


  • Hello,

    I was trying to set up FOG on some HP elitedesk Windows 10 machines to capture and deploy images. But after downloading the FOG client, add the machine to the server and trying to capture its image, nothing happens.

    When I looked into the BOOT order, I noticed that the PXE boot on the machine we want to image doesn’t connect to FOG (the FOG ascii art doesn’t pop up) and our network engineers do not see any traffic between the machine and the server. From what I understand they aren’t able to ping the server from their side as well.

    Has anyone encountered something like this before?


  • @rrtern Just wondering, did you create a route between the two subnets? The firewall(s) may also need rules to allow pxe, http, and tftp traffic between those subnets. I didn’t see anything mentioned about routes so that’s why I asked. For instance in pfsense, by default different VLANs can communicate with each other. But at my job’s network environment they have to create routes so that vlans and subnets can communicate.

  • Moderator

    @jape Do you have control of your subnet router? If yes can you add a dhcp server (fog server’s IP address) to the dhcp-helper/relay service in the router?

    The thought is to provide just pxe boot info we will use dnsmasq. The only thing is if you have multiple ip subnets, the dnsmasq service needs to hear the pxe boot request. It will only provide pxe boot info everything else comes from your main dhcp server. We use this method when the dhcp server can’t be modified or is broken and can’t provide the proper pxe boot info.


  • @george1421 Thanks. The existing DHCPD server is not adminstrated by us. Its managed somewhere else by another group. I can reserve a certian segment of the range , but thats about it It sounds like maybe it will be simpler to have a separate FOG server in each subnet.

  • Moderator

    @jape said in FOG unable to PXE boot beyond the VLAN/subnet that the server is on:

    So perhaps that will complicate things

    Yes it will. dhcp works off from broadcast messages, so it communicates by sending out broadcast messages on the same vlan/network. Having 2 dhcp servers on the same network segment will cause you grief.

    Fog can integrate into an environment where there is an existing dhcp server no problem. FOG’s internal dhcp server would be typically used if you were to setup an isolated imaging network where there was no device except the pxe booting computer and the fog server.

    So lets start out with this, what device is your preexisting dhcp server?


  • @george1421 ok I see. Yes, there is a separate DHCP server serving a separate range within that same subnet. So perhaps that will complicate things

  • Moderator

    @jape Just to be clear you did not have a preexisting dhcp server on your site until fog was installed? Not even a router or other device that acted in place of a traditional dhcp server? its a bit strange (I feel) that you would have vlans/subnets without an existing dhcp server.

    If this is true, no worries its pretty simple to get the remote subnets to work.


  • This post is deleted!

  • Thanks @george1421
    Well, we did not have a separate dhcp server in our environment when we setup FOG. So we used the same server. If this isn’t advisable we can probably move the service to another host

  • Moderator

    @jape said in FOG unable to PXE boot beyond the VLAN/subnet that the server is on:

    The Fog server is a Ubuntu 18 system it is also the DHCPD server .I have not changed the option 66 or 67.

    OK now we have a direction. So can you tell me why you are using the FOG server as a dhcp server? Do you have a campus dhcp server or is FOG on a dedicated imaging network.

    The question is not as cheeky as it sounds. There are valid use cases for having FOG be the dhcp server, I just want to make sure you have one of those cases.


  • @george1421 said in FOG unable to PXE boot beyond the VLAN/subnet that the server is on:

    FOG iPXE menu

    So specifically on subnet A where the FOG server is located we see the FOG iPXE menu when any system boots to network card. Everything works great . On subnet B we don’t see the FOG iPXE menu when a system boots to ethernet.

    The Fog server is a Ubuntu 18 system it is also the DHCPD server .I have not changed the option 66 or 67.

  • Moderator

    @jape said in FOG unable to PXE boot beyond the VLAN/subnet that the server is on:

    VMs we see the FOG client menu

    I’m still battling terminology here. The FOG Client is an application that gets installed on a target computer. The FOG Client is responsible for contacting the fog server post deployment for scheduled tasks. That is different than the FOG iPXE menu which is what you get to via pxe booting.

    So on both subnets what device is your dhcp server? You need to make sure the dhcp scopes for each vlan have dhcp options 66 and 67 set correctly. 66 should be the IP address of the fog server and dhcp option 67 should be undionly.kpxe for a bios computer and ipxe.efi or snp.efi for a uefi computer. FOG images correctly across subnets as long as the network packets are routable across your subnets.


  • @george1421

    Hi George, I am working with Rich in our lab. Specifically we havea group of VMs on the same VLAN and subnet as the FOG server . Each time we boot to legacy ethernet on those VMs we see the FOG client menu that rich descibe. Buuut , although we have set up IP helpers on the switch when we boot physical machines on a separate VLAN/Subnet we are not getting an IP and seeing the PXE boot.

    FOG server is running on an Ubuntu server . I am not clear where to change the DHCP settings?

  • Moderator

    @rrtern There are a few gaps in what you have said you have done so far.

    Have you configured your dhcp server dhcp options 66 and 67 correctly?
    Do you get to the FOG iPXE menu at all?

194
Online

9.8k
Users

16.1k
Topics

148.5k
Posts