• Moderator

    @sourceminer OK the exports file is correct. I wanted to make sure the /imagesX/dev directories were rw and the /images were ro.

    So what I found strange is that the /ntfs directory is empty. It should not be empty (I think). Hopefully you are still at that command prompt. Key in df -h to see if you have mounted the fog server. I think we are at the point of the error, we just need to find out why with this computer the capture isn’t working.

    Also confirm that you can ping the fog server.

    Wait, I think I have a capture mixed with a deployment. Try /images on the target computer instead of /ntfs. See if that directory has stuff.


  • Here is the debug mode.
    Exports file again:

    07e0ce8a-761e-4783-85b3-9aa5dc731d07-image.png


  • @george1421 - Its seems that it has been successful in writing some files. Not sure what the issue is. I did the debug prior to the message / post and no errors that I could see outside the one that is in the screenshot.

    Seems the capturing process is running and writing the files as root.
    I tried to change as fogproject.root before image is complete, but curious why its now doing this.

    a71f6f7a-4858-4a5e-acc8-dc0fa23f3f7c-image.png


  • @george1421
    I have been successful in capturing 2 other images so far… Not sure why permissions would change. I will try to run in debug.

  • Moderator

    @sourceminer I’m going think that its a permission issue since you are using the /images2 repository.

    How I would debug this is actually by setting up a capture again, but tick the debug checkbox before scheduling the task.

    pxe boot the target computer.
    press enter until are dropped to the fos linux command prompt
    key in fog on the target computer to start to single step through the deployment
    keep pressing enter until you get the above error screen
    press ctrl-c
    change to the /ntfs directory (this should be the share mounted on the fog server in the /images2/dev location.
    On the fog server run this command touch /images2/dev/test.txtthat should create the file in the images2/dev directory.
    Can you see that from the target computer?
    On the target computer can you run this command rm /ntfs/test.txt Does it complete successfully?

    Somewhere here we should hit a permission issue.

    Also please post your /etc/exports file from the fog server here.

347
Online

9.7k
Users

16.1k
Topics

148.4k
Posts