Cannot find disk on system (getHardDisk)


  • The company I work for just bought a ton of these HP 250 G8 laptops. I am new to Fog, but for the most part, I have the server running as it should on CentOS-7 and Fog 1.5.9…

    I am trying to capture the image of this laptop and it goes through the motion, but once it boots into pxe, it does its thing, i see the Fog Opensource Ghost screen and then an error:
    Cannot find disk on system (getHardDisk).

    I followed this url and I was able to capture the first image - https://forums.fogproject.org/topic/15826/updating-compiling-the-latest-version-of-ipxe
    Then i tried to capture a new image and now getting the same error as before.

    Please help.

  • Moderator

    @rubix8 OK there are a few things here, but lets try the easiest first.

    FOG has two components. One is iPXE. If you can get to the FOG iPXE menu then its not an iPXE issue. The second part once you make a selection on the FOG iPXE menu bzImage and init.xz are transferred to the target computer. That is FOS Linux. You should make sure your FOS Linux kernel is up to date. You do that via the Web UI -> FOG Configuration -> Kernel update. You should download 5.15.x series for both x64 and x32 kernels. That will (should) take care of the can’t get hard disk. If it does not then we will debug more.

344
Online

9.7k
Users

16.1k
Topics

148.4k
Posts