• My FOG server is running on Centos 7 fully updated, and I am working on getting a FOG image deployed to several Lenovo Thinkbook G2 ITL Laptops. I have verified FOG is running 1.5.9, BZImage is 5.15.19, and updated iPXE to newest version. I have turned off secure boot, changed DHCPD to try snp.efi, ipxe.efi, realtek.efi (Lenovo’s use realtek cards) and when I use any of those it fails to configure the network card.

    I manually added the host and mac address to test running it as well. When I run DHCPD as snponly.efi is that is where the BZImage gets to either 0, 18, 27, 30, or 40% and stops. I have enclosed a picture of the screen.BZImage Lockup

  • Moderator

    @rayne Well this isn’t getting us to a solution then. The issue is between the uefi firmware and iPXE. If your firmware is up to date on this system (please check), then we will probably need to create a usb boot disk to load into FOG imaging. You will lose some capabilities that iPXE has but you can unicast image with this route.

    First check the firmware then if that is up to date I can give you guidance on how to create a FOG usb boot drive.


  • @george1421
    Yeah, I used the FOG scripts to do the rebuild per the guide. The lockup was occuring prior to the iPXE update as well, so doing due diligence I made sure to properly update and rebuild the iPXE to 1.21 through FOG.

  • Moderator

    @rayne said in BZImage Locking Up:

    Yeah, once the iPXE was downloaded, I recompilied it and rebooted the server.

    Just to be clear you use the FOG scripts to rebuild iPXE? FOG adds some scripts to the ipxe boot loader to make it work correctly. That is why I asked.

    The partially transferring bzImage is related to iPXE and how it interacts with the hardware specifically the network adapter. So its not the kernel or FOS Linux (cause it hasn’t got there yet). bzImage is the kernel in this context.


  • @george1421
    Yeah, once the iPXE was downloaded, I recompilied it and rebooted the server. I tested the system on a Dell Optiplex 990 with UEFI and it gets to the input information screen post BZImage host registration.

  • Moderator

    @rayne said in BZImage Locking Up:

    updated iPXE to newest version.

    So did you recompile the iPXE boot loader using the FOG server?

    Can you boot into fog imaging with a different model computer (but still uefi) connected to this same network cable?

362
Online

9.7k
Users

16.1k
Topics

148.4k
Posts