• Hello,

    I wanted to move my /images directory to /zfs/images and unfortunately, I didn’t think much about it and just moved the files manually and changed the path in the default storage unit.

    Now it’s throwing that it cannot mount /images/dev on /zfs/images because of some permissions missing. Is there any way to fix it?

    Thanks in advance!


  • @jas777 nevermind, turned out to be a TP-Link switch not multicasting properly for some reason, everything works now!


  • @george1421 so I’ve done everythinf that you’ve said would help and I’m faced with a connection timed out on mounting the images. The /proc/cmdline shows that the storage is set to my.servers.ip.addr:/zfs/images/dev


  • @george1421 thanks for the tip 😃

  • Moderator

    @jas777 other commands you might need

    showmount -e 127.0.0.1 (executed on the fog server) will list the NFS shares. This needs to match what the FOS engine will be told to connect to.
    set
    The exports file must match what you wanted exported from the FOG server. In this case the lines should have /zfs/images and /zfs/images/dev

    If you schedule a task in debug mode and then pxe boot the target computer it will drop you at the fos linux command prompt. At that command prompt key in set or cat /proc/cmdline make sure the path being told to FOS Linux matches /zfs/images. If yes then you have the fog server configured correctly. I know this is a lot of extra background info, but if something goes wrong you have the tools you need to find out why.


  • @jas777 nevermind, the installer just crashed on restarting VSFTPD cause I have it in standalone mode, it created the exports correctly. Will let you know if it works on monday! 😄


  • @george1421 96882249-b91d-49d9-82a1-d40bd370f155-image.png

    I’m not sure if it should look like that 😕

  • Moderator

    @jas777 Yes there is a way there are a number of additional steps but it can be done.

    make the directory structure /zfs/images

    Now update the fog installer configuration file in /opt/fog/.fogsettings there should be a path in there that lists /images change it to /zfs/images. Now rerun the installer. It “should” recreate the images directory structure with the needed hidden files.

    Once that is done inspect /etc/exports file make sure that is pointing to the proper path.

    Then in the web ui look at the storage manager and at the default storage node. Set the paths in there. Lastly in the web uid -> fog configuration -> fog settings hit the expand all button. Search there for /images and fix it up. I don’t think there is a value in there, but if there was, that is the location it will be.

    Once you have all of the changes set reboot the fog server and test.


  • @george1421 okay, and is there any way to have the images in a subdirectory of /zfs (/zfs/images) or do I have to dedicate a whole partition/device to it?

  • Moderator

    @jas777 Once you have the directories exchanged where your zfs drive is mounted as /images run the fog install script once again. It will select your previous selections. The idea is to have the fog installer fix the now remounted /images directory. Once the permissions are set correctly look at the settings then copy the image files from /images-old over to the zfs drive. Confirm the permissions are set correctly. If you created any new post install or post init scripts move them over too. Confirm you can capture and deploy to the zfs disk. Once everything is good then purge the /images-old directory.

    If you altered the /etc/exports file correct them. By keeping the directory the same as what FOG has defined will make things easier. How things are connected at the OS level is up to you.

  • Moderator

    @jas777 Ok after looking at the lsblk cmd again I see what you are doing the /zfs mount has both /dev/sda and /dev/sdb behind it.

    There is a way to fix this. There is an easy way and a bit harder way.

    The easy way is to rename /images to /images-old Then rename the zfs mount to /images.

  • Moderator

    @jas777 So it looks like the /zfs mount is an nfs mount to another system?

    If so that isn’t going to work; You can reshare a network mounted share. Its roughly equivalent to mounting a network shared drive on your windows server as the W: drive, then trying to share out that W: drive to another computer.

    In linux the nfs server can’t follow that path.


  • @george1421

    lsblk:

    NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
    loop0    7:0    0  49,8M  1 loop /snap/snap-store/467
    loop1    7:1    0 255,6M  1 loop /snap/gnome-3-34-1804/36
    loop2    7:2    0     4K  1 loop /snap/bare/5
    loop3    7:3    0  55,5M  1 loop /snap/core18/2344
    loop4    7:4    0  61,9M  1 loop /snap/core20/1494
    loop5    7:5    0    47M  1 loop /snap/snapd/16010
    loop6    7:6    0 254,1M  1 loop /snap/gnome-3-38-2004/106
    loop7    7:7    0  54,2M  1 loop /snap/snap-store/558
    loop8    7:8    0   219M  1 loop /snap/gnome-3-34-1804/77
    loop9    7:9    0  44,7M  1 loop /snap/snapd/15904
    loop10   7:10   0 248,8M  1 loop /snap/gnome-3-38-2004/99
    loop11   7:11   0  55,5M  1 loop /snap/core18/2409
    loop12   7:12   0  81,3M  1 loop /snap/gtk-common-themes/1534
    loop13   7:13   0  61,9M  1 loop /snap/core20/1518
    loop14   7:14   0  65,2M  1 loop /snap/gtk-common-themes/1519
    sda      8:0    0   3,7T  0 disk
    ├─sda1   8:1    0   3,7T  0 part
    └─sda9   8:9    0     8M  0 part
    sdb      8:16   0   3,7T  0 disk
    ├─sdb1   8:17   0   3,7T  0 part
    └─sdb9   8:25   0     8M  0 part
    sdc      8:32   0    68G  0 disk
    ├─sdc1   8:33   0   512M  0 part /boot/efi
    ├─sdc2   8:34   0     1K  0 part
    └─sdc5   8:37   0  67,5G  0 part /
    sr0     11:0    1  1024M  0 rom
    

    df -h:

    System plików  rozm. użyte dost. %uż. zamont. na
    udev             16G     0   16G   0% /dev
    tmpfs           3,2G  2,1M  3,2G   1% /run
    /dev/sdc5        66G   29G   34G  47% /
    tmpfs            16G  8,0K   16G   1% /dev/shm
    tmpfs           5,0M  4,0K  5,0M   1% /run/lock
    tmpfs            16G     0   16G   0% /sys/fs/cgroup
    /dev/loop0       50M   50M     0 100% /snap/snap-store/467
    /dev/loop1      256M  256M     0 100% /snap/gnome-3-34-1804/36
    /dev/sdc1       511M   24K  511M   1% /boot/efi
    data-1          3,6T  546G  3,0T  16% /zfs
    /dev/loop2      128K  128K     0 100% /snap/bare/5
    /dev/loop3       56M   56M     0 100% /snap/core18/2344
    /dev/loop4       62M   62M     0 100% /snap/core20/1494
    /dev/loop5       47M   47M     0 100% /snap/snapd/16010
    /dev/loop7       55M   55M     0 100% /snap/snap-store/558
    /dev/loop8      219M  219M     0 100% /snap/gnome-3-34-1804/77
    /dev/loop6      255M  255M     0 100% /snap/gnome-3-38-2004/106
    /dev/loop9       45M   45M     0 100% /snap/snapd/15904
    /dev/loop10     249M  249M     0 100% /snap/gnome-3-38-2004/99
    /dev/loop11      56M   56M     0 100% /snap/core18/2409
    /dev/loop12      82M   82M     0 100% /snap/gtk-common-themes/1534
    /dev/loop13      62M   62M     0 100% /snap/core20/1518
    /dev/loop14      66M   66M     0 100% /snap/gtk-common-themes/1519
    tmpfs           3,2G   16K  3,2G   1% /run/user/125
    tmpfs           3,2G  8,0K  3,2G   1% /run/user/1001
    
  • Moderator

    @jas777 What does the output of this command suggest"
    lsblk
    and
    df -h

334
Online

9.6k
Users

16.0k
Topics

147.9k
Posts