• Hello Comunity,
    have only one Red Hat Enterprise running as an image?

    not wortking

    kernel tftp://${fog-ip}/os/redhat/r9/vmlinuz
    initrd tftp://${fog-ip}/os/redhat/r9/initrd.img
    imgargs vmlinuz initrd=initrd.img root=live:nfs://${fog-ip}:/images/os/redhat/r9 ip=dhcp inst.repo=nfs:${fog-ip}:/images/os/redhat/r9/ splash quiet
    boot || goto MENU


  • fixed from me and working

    kernel tftp://${fog-ip}/os/redhat/r9/vmlinuz
    initrd tftp://${fog-ip}/os/redhat/r9/initrd.img
    imgargs vmlinuz initrd=initrd.img root=live:nfs://${fog-ip}:/images/os/redhat/r9/images/install.img ip=dhcp inst.repo=nfs:${fog-ip}:/images/os/redhat/r9/BaseOS splash quiet
    boot || goto MENU


  • fixed from me and working

    kernel tftp://${fog-ip}/os/redhat/r9/vmlinuz
    initrd tftp://${fog-ip}/os/redhat/r9/initrd.img
    imgargs vmlinuz initrd=initrd.img root=live:nfs://${fog-ip}:/images/os/redhat/r9/images/install.img ip=dhcp inst.repo=nfs:${fog-ip}:/images/os/redhat/r9/BaseOS splash quiet
    boot || goto MENU

  • Moderator

    @nowin You need to be a bit more descriptive to what “it” is an not working.

    I have not used RedHat since they messed up Centos and I walked away. So I’ve had no experience with trying to netboot it.

    Your command and image args look good and what I might expect. The only thing I might think is the inst.repo field. If that’s supposed to be a URI path it should be nfs://${fog-ip} and not nfs:${fog-ip} but that is really up to how the boot script is handled in the os.

    How far does it get in the booting process? Do you see it transfer vmlinuz and initrd?

    If your kernel isn’t setup for verbose reporting you might add loglevel=7 as a kernel parameter. Understand that will spit out a lot of data but you might see what its complaining about.

260
Online

9.8k
Users

16.1k
Topics

148.5k
Posts