• Hi all,

    I have a quick question. We have FOG working and deploying images as it should, and it works great. However, after we image the windows pc and partclone finishes and reboots the PC, the BIOS order is set to PXE boot #1, meaning we have to manually go back into the bios and change the boot order to HDD #1.

    Is this something we can change in FOG so it change the order to boot into the image, or do we just have to manually change it everytime?

    We are working with newer Dell PCs and laptops.

    Thanks for your assistance!


  • @jdakel did u try CCTK by Dell ?
    it allows you to modify bios from your chair

  • Moderator

    @jdakel FOG doesn’t touch uefi / bios settings, not even on a good day. Typically when you sysprep and image and let windows go through WinSetup/OOBE windows will reset the boot order. FOG Admins usually complain because Windows does this, where they want to boot through pxe boot.

    Now with that said I see you have 2 options.

    1. Leave the boot order for the local hard drive first and use the F12 boot manager to select PXE boot. This is how I run FOG on my campus. I require the IT Tech to sit in front of the computer and manually select PXE boot to begin imaging.

    2. Create a FOG Post Install script that calls the linux utility efibootmgr and pass the proper command line switches to the efibootmgr utility to change the boot order.

344
Online

9.6k
Users

16.0k
Topics

147.9k
Posts