FOG isnt deploying on new laptops.


  • I know this is just a small step im missing in the process. We just received 30 brand new lenovo E14 ThinkPads, theyre all set up, win10 pro, hostname and joined to the domain, updated secure boot off, but when I try to start the deployement Im getting the "No configuration methods succeded - DHCP failed. im not sure what in the process im getting wrong.!! heres a pic of the error.

    (https://imgur.com/fwjZcEv)

    Thanks guys for any help!

    PS: I run deploys all the time and theres no issue only with these new laptops.


  • That work now, thank you !

  • Moderator

    @larmurier1383 OK I see. You do not get to FOG iPXE menu. That has a different fix to try. There are 2 spots where that same message appears. I was thinking the error was on the second location. But you are stuck on the first location (no iPXE menu)

    I give you instructions to update the version of iPXE to the newest release. This might fix the problem because the updated version of iPXE will have the newest hardware drivers.

    https://forums.fogproject.org/topic/15826/updating-compiling-the-latest-version-of-ipxe


  • @george1421 So here is my main problem :

    2022-04-15_15h31_17.png


  • @george1421 Sorry im on work ill text you later when i can thank’s for the help !

  • Moderator

    @larmurier1383 OK We find out a bit more what is happening here.

    1. The uname -a command tells us that you are still running 4.19.x kernel and not 5.15.x. We need to fix that because 4.19 doesn’t have drivers for new hardware.

    2. Not sure why grep is not found, it should be on all computers. Try sudo apt-get install get This might not be important because we can see in the next command

    3. For ip a s it shows your network interface has an IP address. This should not be if we get the “No configuration methods succeeded”

    It may be a translation issue but this statement give me a problem. " i have uptdate my bzImage and bzimage32 on 5.15.19 version but i still have te same error “no configuration method succeded” but not having the DHCP failed"

    Does this mean the pxe boot computer gets IP address, but still give message about no configuration methods? If yes, can you ping the fog server from the computer in debug mode?

    EDIT: STOP! I see the problem

    You entered those commands I give you on the FOG server. That is not what I wanted. I wanted you to enter those commands on the pxe boot computer you started in debug mode. That is why the information you give did not do what I expected.


  • @azer I have updated the 2 version (i guess?..) 2022-04-15_14h42_22.png

    for the uname -a : 2022-04-15_14h44_19.png

    2022-04-15_14h45_12.png 2022-04-15_14h45_43.png

    Hope we can find a solution !

  • Moderator

    @larmurier1383 Well first thing I noticed is that you need to make sure that you updated the 64 bit version of FOS Linux kernel. You only mentioned the 32 bit version.

    Next thing I want you to do is schedule another capture/deploy it doesn’t matter. But before you hit the schedule task button enable the debug check box.

    Now pxe boot the target computer into imaging.

    After several pages of text that you need to clear with the enter key you will be dropped at the fos linux command prompt (note that you still should see the error about no configuration methods, that is OK because we need debug mode to see what is going on).

    Now at the FOS Linux command prompt I want you to key in the following and post the results here. (you might want to take clear picture shot with a mobile phone and post it)

    uname -a

    lspci -nn | grep -i net

    ip a s

    Lets see what these commands can find.


  • @maxcarpone Hi, i try on Thinkpad E15 Gen 2 and still can’t boot with 4.19.x or 5.15.x version !


  • @bofh Hi, i try on Thinkpad E15 Gen 2 and still can’t boot with 4.19.x or 5.15.x version… I dont understand why


  • HI @george1421 i have uptdate my bzImage and bzimage32 on 5.15.19 version but i still have te same error “no configuration method succeded” but not having the DHCP failed

    Its a LENOVO E15 this time


  • Interesting, I’ve been able to deploy to E14 Gen 3’s without that issue.
    I’m running FOG version 1.5.9
    Kernel versions:
    bzImage Version: 4.19.145
    bzImage32 Version: 4.19.145


  • Thanks guys, I will look into this on Monday and if i come to a solution will post the steps I took

  • Moderator

    @azer Yes this is a problem with iPXE not FOS Linux “the kernel”. But with the E14 both @Larmurier1383 and @maxcarpone are right. You need to rebuild iPXE to get the latest hardware support as well as when you start imaging you will need the 5.15.x version of the FOS Linux kernel.

    The simple rule is if you can’t get to the FOG iPXE menu then the problem is in iPXE (unidonly,kpxe or ipxe.efi). If you can get to the FOG iPXE menu but you get an error after you pick a menu item then the issue is in FOS Linux kernel (bzImage).


  • Morning,

    Have you tried to update kernels of your FOG Server guys? To do so, you click on “Fog Configuration” then “DefaultMember FOG Version” to display both running kernels (mines are 5.15.19 for example).

    Then you click on Kernel Update in left panel. You pick those 5.xx.xx kernels Intel 64 Bits and Intel 32 Bits and download them to start the installation process.

    You probably need a 5.xx kernel and don’t have it installed.

    Let us know if it works 🙂


  • Hello, i have the same error with our E14, i’m trying to do :
    https://forums.fogproject.org/topic/15826/updating-compiling-the-latest-version-of-ipxe

    If the problem is solved I will tell you.

    Good luck, at least i use CloneZilla for not wasting time for my customer, but its it’s disabling to do with.

357
Online

9.6k
Users

16.0k
Topics

147.9k
Posts