• Hi there,

    I’m trying to build FOS inits and kernel. Running fogproject/fos-builder on top of my windows docker desktop.

    with cmds
    winpty docker run -v c:\\Gits\fos:/home/builder/fos:Z -u builder -it fogproject/fos-builder
    cd /home/builder/fos
    ./build.sh -n

    changes made to build.sh
    https://github.com/FOGProject/fos/blob/master/build.sh#L156
    wget --no-check-certificate -q $brURL && echo “Done”
    to bypass certification error while downloading buildroot.

    it seems failed at the “checking target system type… x86_64-pc-linux-gnu” beside the warning on the clock skew detected at the beginning of the build.

    73553b96-a42b-4141-8a3f-07bb63e1f561-image.png
    c7e99122-ee7d-4806-a9e6-12eb8be2f2ee-image.png

    Is there any other prerequisite in building FOS aside from the stated https://github.com/FOGProject/fos#what-do-we-need? e.g. it must be build on top of Linux host?

  • Moderator

    @peirkern Sorry for the delay. I have tried to think about what could cause this new error you see but still have not found a good answer to this yet. I checked logs of a good compile on one of my servers and don’t see this error:

    linux-5.10.83.tar.xz: OK (sha256: ef259a43f33ddb56001283f4f4e50af29b8a48fa066aed7371a90ebf38c29b70)
    ESC[7m>>> linux-headers 5.10.83 ExtractingESC[27m
    xzcat /var/lib/.../fssourcex64/dl/linux/linux-5.10.83.tar.xz | tar --strip-components=1 -C /var/lib/.../fssourcex64/output/build/linux-headers-5.10.83   -xf -
    ESC[7m>>> linux-headers 5.10.83 PatchingESC[27m
    ESC[7m>>> linux-headers 5.10.83 ConfiguringESC[27m
    ...
    

    I can only suggest you start playing with the commands within docker and see what happens:

    mkdir ~/test
    xzcat /home/builder/fos/fssourcex64/dl/linux/linux-5.10.83.tar.xz | tar --strip-components=1 -C ~/test -xf -
    

  • @quazz thanks. Disabling WSL2 is helping, it is able to proceed until it hit below error…

    linux-5.10.83.tar.xz: OK (sha256: ef259a43f33ddb56001283f4f4e50af29b8a48fa066aed7371a90ebf38c29b70)
    >>> linux-headers 5.10.83 Extracting
    xzcat /home/builder/fos/fssourcex64/dl/linux/linux-5.10.83.tar.xz | tar --strip-components=1 -C /home/builder/fos/fssourcex64/output/build/linux-headers-5.10.83   -xf -
    chmod: changing permissions of '/home/builder/fos/fssourcex64/output/build/linux-headers-5.10.83/drivers/gpu/drm/nouveau/nvkm/subdev/i2c/aux.c': No such file or directory
    chmod: changing permissions of '/home/builder/fos/fssourcex64/output/build/linux-headers-5.10.83/drivers/gpu/drm/nouveau/nvkm/subdev/i2c/aux.h': No such file or directory
    chmod: changing permissions of '/home/builder/fos/fssourcex64/output/build/linux-headers-5.10.83/include/soc/arc/aux.h': No such file or directory
    package/pkg-generic.mk:170: recipe for target '/home/builder/fos/fssourcex64/output/build/linux-headers-5.10.83/.stamp_extracted' failed
    make: *** [/home/builder/fos/fssourcex64/output/build/linux-headers-5.10.83/.stamp_extracted] Error 1
    

    https://drive.google.com/file/d/1h_gpNpZkYzylAC7m5EKj-Q60IizezyCL/view?usp=sharing

  • Moderator

    @peirkern Ok, looks you’re doing this on Windows docker, which means it is using WSL2 as a backend.

    https://github.com/libffi/libffi/issues/552

    It seems that it doesn’t behave correctly in that environment currently (that specific package that is).

    You might run into other problems as well if you’re unlucky.

    You can try disabling WSL2 in docker settings and see if that helps.


  • @quazz @Sebastian-Roth . Thanks for your replies.

    I had checked that I have sufficient disk space and rebuild the fos-builder locally, it solved the clock skew and cert issues.

    docker build -t local/fos-builder .
    

    and continue with

    winpty docker run -v c:\\\\Gits\\fos:/home/builder/fos:Z -u builder -it local/fos-builder
    ./build.sh -n
    

    It still failed at

    checking build system type... x86_64-pc-linux-gnu
    checking host system type... x86_64-pc-linux-gnu
    checking target system type... x86_64-pc-linux-gnu
    continue configure in default builddir "./x86_64-pc-linux-gnu"
    ....exec /bin/bash .././configure "--srcdir=.." "--enable-builddir=x86_64-pc-linux-gnu" "linux
    gnu"
    configure: WARNING: unrecognized options: --disable-gtk-doc, --disable-gtk-doc-html, --disable-doc, --disable-documentation, --with-xmlto, --with-fop, --disable-nls
    .././configure: line 2304: config.log: No such file or directory
    .././configure: line 2314: config.log: No such file or directory
    cat: standard output: No such file or directory
    package/pkg-generic.mk:231: recipe for target '/home/builder/fos/fssourcex64/output/build/host-libffi-3.3/.stamp_configured' failed
    make: *** [/home/builder/fos/fssourcex64/output/build/host-libffi-3.3/.stamp_configured] Error 1
    

    for complete logs, kindly refer https://drive.google.com/file/d/1EB3fxsh5sXTRZ1LkxuwNLrIs8I87hXuR/view?usp=sharing

  • Moderator

    @peirkern Both the “clock skew” and certificate failures would indicate a problem with your clock/datetime on the docker image, though the echo’d output seems to indicate it’s fine (or close enough anyway).

    Still, can’t hurt to doublecheck?

  • Moderator

    @peirkern Sorry for my late answer. I’ve been too busy with other things.

    The errors posted seem very strange but I don’t think they are actually causing the build to fail. Never the less I manually tried those URLs and I don’t get any certificate error (using wget and browsers).

    I tried to compare your build log with one of mine. Right where you build fails my log looks like this:

    ...
    configure: WARNING: unrecognized options: --disable-gtk-doc, --disable-gtk-doc-html, --disable-doc, --disable-documentation, --with-xmlto, --with-fop, --disable-nls
    checking build system type... x86_64-pc-linux-gnu
    checking host system type... x86_64-pc-linux-gnu
    checking target system type... x86_64-pc-linux-gnu
    continue configure in default builddir "./x86_64-pc-linux-gnu"
    ....exec /bin/bash .././configure "--srcdir=.." "--enable-builddir=x86_64-pc-linux-gnu" "linux
    gnu"
    configure: WARNING: unrecognized options: --disable-gtk-doc, --disable-gtk-doc-html, --disable-doc, --disable-documentation, --with-xmlto, --with-fop, --disable-nls
    checking build system type... x86_64-pc-linux-gnu
    checking host system type... x86_64-pc-linux-gnu
    checking target system type... x86_64-pc-linux-gnu
    checking for gsed... sed
    ...
    

    No idea why this fails for you. Maybe check simple things first: enough free disk space??


  • @sebastian-roth , here is it. no sure whether it is related to wget cert.

    https://drive.google.com/file/d/1w713cCq56mp0S0hBS_i-UWR2MBs8obvY/view?usp=sharing

    l193
    ERROR: The certificate of ‘distfiles.dereferenced.org’ is not trusted.
    ERROR: The certificate of ‘distfiles.dereferenced.org’ has expired.
    l542
    ERROR: The certificate of ‘www.kernel.org’ is not trusted.
    ERROR: The certificate of ‘www.kernel.org’ has expired.
    l1883
    ERROR: The certificate of ‘www.kernel.org’ is not trusted.
    ERROR: The certificate of ‘www.kernel.org’ has expired.
    l5884
    ERROR: The certificate of ‘snapshot.debian.org’ is not trusted.
    ERROR: The certificate of ‘snapshot.debian.org’ has expired.

  • Moderator

    @peirkern From the information posted so far I can’t see what is causing the build to fail. Would you mind uploading the whole log file (fssourcex64/buildrootx64.log) and post a link here?

277
Online

9.5k
Users

15.9k
Topics

147.5k
Posts