• Hello, for unknow reason i can’t deploy to the Asus BR1100CKA, i get I/O Error and fsync error

     I/O Error and fsync erro

    We use the lastest fog version on the dev branch with the latest FOS on utbuntu 20.04.

    Never had this error before we use the image already and its working. I feel like i’ts a missing driver or something.

  • We found the solution. For anyone having the same problem with a emmc G1J39E, use the kernel arguments


    we found the answer right here

  • Moderator

    @alicevintage-0 said in Deploy to ASUS BR1100CKA:

    The nvme option has nothing that i can toggle in it.

    Ok, really strange this has a selection dialog at all.

    Well, I would try installing Windows to see if that prepares the disk in a certain way we don’t know yet. Then deploy your Linux OS “on top” (wiping Windows).

    The other thing you can test is manually installing Linux and see if that works.

  • @sebastian-roth First Picture

    Sata configuration

    The nvme option has nothing that i can toggle in it.

  • Moderator

    @alicevintage-0 said in Deploy to ASUS BR1100CKA:

    We’ve not tried to install linux manually but a standart install of windows seems to work.

    Have you read the topics I posted earlier? All of them say installing Windows is no problem but Linux fails.

    The ahci menu has nothing except select disk mode with the only option being ahci.

    Can you please post a picture of that here?

  • @sebastian-roth We’ve not tried to install linux manually but a standart install of windows seems to work. The ahci menu has nothing except select disk mode with the only option being ahci.

  • @sebastian-roth The partition mmcblk0p1 is definitly windows efi since the os of the image is windows 10. Interestingly i can format the first partition of 100m just fine with mkfs.vfat. But when i try to format the second partition i can’t format it even if i try to format it in ntfs i get the same error as fog get. Our 3 asus get the same error.

  • Moderator

    @AliceVintage-0 Doing a little research on the device you mentioned I found someone having an issue installing Linux on that in general: https://bodhilinux.boards.net/post/5578/thread (despite the same name, it’s not me who posted this)

    And there is another topic here, though this is in French language: https://forum.ubuntu-fr.org/viewtopic.php?id=2069831 (using online translator should help)

    While they can’t solve the problem in the end there is an interesting note about AHCI mode in that later forum topic. Please check the BIOS/UEFI settings and take a picture of the screen where you find the disk mode/AHCI settings and post that here.

    By the way, have you tried to manually install any kind of Linux OS on that device before?


    … for the model i get G1J39E …

    More searching revealed this topic: https://www.elektroda.pl/rtvforum/topic3821300.html

    Translation: […] with this problematic eMMC disk for newly installed Linux. […] So, with the eMMC disk prepared, I launched this paw from Xubuntu 21.04 live loaded on a pendrive via USB (wBIOS / UEFI I set booting to a pendrive from Xubuntu) and installed Xubuntu on the free space of this eMMC. […]

    I have no idea what “eMMC disk prepared” means as there are not more details in this topic.

  • Moderator

    @alicevintage-0 OK with is target computer in the broken state, lets go back into debug mode. Error #5 indicates a bad disk sector. Lets see if we can create the partitions and format them by hand.

    It looks like you are trying to write a linux efi image to the disk.

    Since your partitions have already been created lets see if we can format that 100MB partition (that is where it is failing)

     mkfs.vfat /dev/mmcblk0p1 

    If that fails for some reason document the error, then use fdisk to erase all of the partitions and then put them back as shown with lsblk. What we are testing is that

    1. Is the disk really bad?
    2. Did the partitions get created in a strange way?
    3. Can we make the disk usable?

    If the mkfs.vfat works then run mkfs.ext4 /dev/mmcblk0p2

    Then we should mount both and see if they accept a file (using md5sum compare the hash values)

  • @sebastian-roth I’m having hard time finding info about the disk, for the model i get G1J39E, lshw return nothing for the disk and hdparm also nothing. In the mint gui utility for disk the disk is return as an SD CARD READER of 128G.

  • Moderator

    @alicevintage-0 said in Deploy to ASUS BR1100CKA:

    The disk is supposed to be a 128G Emmc.

    Please share some more details on what eMMC exactly you have. This way we can try to help do the research and find out what’s wrong.

  • @george1421 MicrosoftTeams-image.png
    The disk is supposed to be a 128G Emmc.
    i’ve also change the value of the primary disk for the host to /dev/mmcblk0 but it’s not working either. The mmcblk0 is definitly selected but i still get i/o error and fsync error.

    Thx for the help!

  • Moderator

    @sebastian-roth I have seen some systems have this mmc memory onboard. Kind of on mobo flash drive. Its typically very small < 32GB for embedded purposes or like chromebooks with embedded storage.

    @AliceVintage-0 Here is how I think we should collect a few more bits about your computer. In the FOG UI stop the current capture/deploy task. Create a new capture/deploy task but before you hit the schedule task button, tick the checkbox for debug then submit the task.

    Now pxe boot the target computer. After a few screens of text you clear with the enter key, you will be dropped to the FOS Linux command prompt.

    At this command prompt key in the following command


    Take a clear picture of the output with a mobile phone and post the results here. This command will tell us the configuration of all storage devices on this computer. I’m suspecting lsblk will return two or more storage drives. Knowing what the drives are called, we can give instructions to image these computers correctly with FOG.

  • Moderator

    @AliceVintage-0 Haven’t seen this one before here in the FOG forums. Can you give us some more details on the drive used. Linux sees it as mmcblk meaning it’s some kind of eMMC or even a SD card?!