• Hello everyone

    I’m currently in a internship for a resource center. So in the resource center we have many different computer and I have set up fog with different image (debian 11, windows 10 32bits and 64bits). So fog work on some computer and i can boot on the fog menu and some won’t boot on the menu and show me error
    pxe-E78 : Could not locate boot server
    pxe-M0F : Exiting PXE ROM

    here is my setting for dnsmasq

    /etc/dnsmasq.d/ltsp.conf:

    # Don't function as a DNS server:
    port=0
    
    # Log lots of extra information about DHCP transactions.
    log-dhcp
    
    # Set the root directory for files available via FTP.
    tftp-root=/tftpboot
    
    # The boot filename, Server name, Server Ip Address
    dhcp-boot=undionly.kpxe,,192.168.1.250
    
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    dhcp-no-override
    
    # inspect the vendor class string and match the text to set the tag
    dhcp-vendorclass=BIOS,PXEClient:Arch:00000
    dhcp-vendorclass=UEFI32,PXEClient:Arch:00006
    dhcp-vendorclass=UEFI,PXEClient:Arch:00007
    dhcp-vendorclass=UEFI64,PXEClient:Arch:00009
    
    # Set the boot file name based on the matching tag from the vendor class (above)
    dhcp-boot=net:UEFI32,i386-efi/ipxe.efi,,192.168.1.250
    dhcp-boot=net:UEFI,ipxe.efi,,192.168.1.250
    dhcp-boot=net:UEFI64,ipxe.efi,,192.168.1.250
    
    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Booting FOG Client", 1
    
    # The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    # Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    # This option is first and will be the default if there is no input from the user.
    pxe-service=X86PC, "Boot to FOG", undionly.kpxe
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe.efi
    pxe-service=BC_EFI, "Boot to FOG UEFI PXE-BC", ipxe.efi
    
    dhcp-range=192.168.1.250,proxy
    

    picture of the error https://ibb.co/kxpwNmL


  • @george1421 Thanks a lot. It was the router that has dhcp and i just turned off the dhcp it work well thanks a lot


  • @george1421 Thanks a lot. It was the router that has dhcp and i just turned off the dhcp it work well thanks a lot


  • @george1421 The computer is plug to a d-link dir-120 so it’s a router i’m going to see if there is any dhcp and i come back to you thanks to you for taking time to respond me

  • Moderator

    @jonathands This in theory should be working. I do see something that make me question.

    First let me say in the ltsp.conf file these are the only rules that apply since its a bios computer.

    # The boot filename, Server name, Server Ip Address
    dhcp-boot=undionly.kpxe,,192.168.1.250
    

    Looking at your picture I can see you are pxe booting a bios based computer. The computer is getting an ip address of 192.168.0.112 with a subnet mask of 255.255.255.0. Your dhcp server and gateway are one device (maybe a soho/home router). The proxy dhcp address is correct according to the ltsp.conf file, so that tells us DNSMASQ is talking to the target computer. So that bit is working.

    Now to the point I’m seeing. The FOG server (I assume is also where dnsmasq is running) is on 192.168.1.250. That is a different subnet than where the computer is at 192.168.0.112. Do you have a router configured to route between the two subnets?

259
Online

9.5k
Users

15.9k
Topics

147.5k
Posts