• Hi,
    I’m trying to do a new FOG installation on CentOS (VM), but the installation gets stuck on Preparing Package Manager.
    I also tried installing it on Debian but it gets stuck on Installing Package: apache2
    Why is the installation not moving forward?

    cap.PNG

  • Moderator

    @anisgh Which version of Debian did you try to install FOG on? I am really wondering what’s going on because the error we see in the output posted doesn’t make sense to me. The package named mariadb-client is available in all current versios of Debian: https://packages.debian.org/search?keywords=mariadb-client&searchon=names&suite=stable&section=all (for stretch, buster, bullseye, even bookworm and sid!)

    Please try installing it manually via apt-get install mariadb-client and see what error you get.

    So either you try to install on Debian 11 - then follow what George posted. Or you are using a really old version of Debian and need to update to a later one first.

  • Moderator

    @anisgh If you are installing Debian 11 and you are not on the dev-branch (a.k.a. fog 1.5.9.114 or later) then lets have you switch over. FOG 1.5.9 GA doesn’t support the latest releases of Centos, Debian, and Ubuntu. FOG 1.5.9.110 and later do.

    If you used the git method to download the fog installer then lets do this:

    cd /root/fogproject  # assuming you initially used that directory for the installer. 
    git pull
    git checkout dev-branch
    git pull
    cd bin
    ./installfog.sh
    

    Lets see if you can run that installer to the end.

    Now when FOG 1.5.10 is released later this spring then you will need to switch the git repository back with

    cd /root/fogproject
    git pull
    git checkout master
    git pull
    cd bin
    ./installfog.sh
    

  • @sebastian-roth to respond to your second question, I’m just trying to install FOG for the first time ever, just gonna try it and get familiar with it that’s all, that is why I’m installing it on a virtual machine (which obviously is connected to the internet).

    Now it would be optimal if I could install it on a Debian distribution, as I mentioned in my question above, the installation got stuck when trying to install apache2. I Installed apache manually and now after running the installation this is what I get:

    * Installation Started
    
    * Testing internet connection.................................Done
    * Adjusting repository (can take a long time for cleanup).....OK
    * Preparing Package Manager...................................OK
    * Packages to be installed:
    
           apache2 bc build-essential cpp curl g++ gawk gcc genisoimage git gzip ht                                                                                                             mldoc isc-dhcp-server isolinux lftp libapache2-mod-php libc6 libcurl4 liblzma-de                                                                                                             v m4 mariadb-client mariadb-server net-tools nfs-kernel-server openssh-server ph                                                                                                             p php-bcmath php-cli php-curl php-fpm php-gd php-gettext php-json php-ldap php-m                                                                                                             bstring php-mysql php-mysqlnd sysv-rc-conf tar tftpd-hpa tftp-hpa unzip vsftpd w                                                                                                             get xinetd zlib1g
    
    
    * Skipping package:   apache2.................................(Already Installe                                                                                                             d)
    * Skipping package:   bc......................................(Already Installe                                                                                                             d)
    * Skipping package:   build-essential.........................(Already Installe                                                                                                             d)
    * Skipping package:   cpp.....................................(Already Installe                                                                                                             d)
    * Skipping package:   curl....................................(Already Installe                                                                                                             d)
    * Skipping package:   g++.....................................(Already Installe                                                                                                             d)
    * Skipping package:   gawk....................................(Already Installe                                                                                                             d)
    * Skipping package:   gcc.....................................(Already Installe                                                                                                             d)
    * Skipping package:   genisoimage.............................(Already Installe                                                                                                             d)
    * Skipping package:   git.....................................(Already Installe                                                                                                             d)
    * Skipping package:   gzip....................................(Already Installe                                                                                                             d)
    * Skipping package: htmldoc...................................(Does not exist)
    * Skipping package: isc-dhcp-server...........................(Does not exist)
    * Skipping package: isolinux..................................(Does not exist)
    * Skipping package: lftp......................................(Does not exist)
    * Installing package: libapache2-mod-php......................OK
    * Skipping package:   libc6...................................(Already Installe                                                                                                             d)
    * Skipping package:   libcurl4................................(Already Installe                                                                                                             d)
    * Skipping package:   liblzma-dev.............................(Already Installe                                                                                                             d)
    * Skipping package:   m4......................................(Already Installe                                                                                                             d)
    * Installing package: mariadb-client..........................Failed! (Will try                                                                                                              later)
    * Skipping package:   mariadb-server..........................(Already Installe                                                                                                             d)
    * Skipping package:   net-tools...............................(Already Installe                                                                                                             d)
    * Skipping package:   nfs-kernel-server.......................(Already Installe                                                                                                             d)
    * Skipping package:   openssh-server..........................(Already Installe                                                                                                             d)
    * Skipping package:   php.....................................(Already Installe                                                                                                             d)
    * Skipping package: php-bcmath................................(Does not exist)
    * Skipping package:   php-cli.................................(Already Installe                                                                                                             d)
    * Skipping package:   php-curl................................(Already Installe                                                                                                             d)
    * Skipping package: php-fpm...................................(Does not exist)
    * Skipping package:   php-gd..................................(Already Installe                                                                                                             d)
    * Skipping package: php-gettext...............................(Does not exist)
    * Skipping package:   php-common..............................(Already Installe                                                                                                             d)
    * Skipping package: php-ldap..................................(Does not exist)
    * Skipping package:   php-mbstring............................(Already Installe                                                                                                             d)
    * Skipping package:   php-mysql...............................(Already Installe                                                                                                             d)
    * Skipping package:   php-mysql...............................(Already Installe                                                                                                             d)
    * Skipping package: sysv-rc-conf..............................(Does not exist)
    * Skipping package:   tar.....................................(Already Installe                                                                                                             d)
    * Skipping package: tftpd-hpa.................................(Does not exist)
    * Skipping package: tftp-hpa..................................(Does not exist)
    * Skipping package:   unzip...................................(Already Installe                                                                                                             d)
    * Skipping package: vsftpd....................................(Does not exist)
    * Skipping package:   wget....................................(Already Installe                                                                                                             d)
    * Skipping package: xinetd....................................(Does not exist)
    * Skipping package:   zlib1g..................................(Already Installe                                                                                                             d)
    * Updating packages as needed.................................OK
    * Installing now everything is updated........................Failed!
    
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !! The installer was not able to run all the way to the end as   !!
    !! something has caused it to fail. The following few lines are  !!
    !! from the error log file which might help us figure out what's !!
    !! wrong. Please add this information when reporting an error.   !!
    !! As well you might want to take a look at the full error log   !!
    !! in /root/fogproject-1.5.9/bin/error_logs/fog_error_1.5.9.log !!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    
    Package mariadb-client is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    E: Package 'mariadb-client' has no installation candidate
    

    I know for sure the installation wasn’t successful, but I can’t understand why

  • Moderator

    @anisgh What the installer does at this stage (“Preparing Package Manager”) is as simple as running yum update (on CentOS) to make sure the package lists are all up to date. In cae you have pending updates those would get installed then. If there are many updates pending this can take a fair amount of time.

    Allow me a question. The hostname seen in the picture suggest you install FOG on a server connected to the internet. There are several reasons we don’t suggest to do this. Or at least you should take caution to secure your FOG server by adjusting things instead of just using default configs.

257
Online

9.5k
Users

15.9k
Topics

147.5k
Posts