FTP Errors



  • Hey Everyone. I hve fog .32 running on ubuntu 11.10.

    I get the following error when I try to start a task:
    [SIZE=16px][FONT=Ubuntu][COLOR=#ff0000][CENTER]Failed to create deploy task[/CENTER][/COLOR][/FONT][/SIZE]
    [SIZE=16px][FONT=Ubuntu][COLOR=#ff0000][CENTER]FOGFTP: Login failed. Host: 192.168.70.81, Username: fog, Password: mypassword, Error: ftp_login(): Login incorrect.[/CENTER][/COLOR][/FONT][/SIZE]
    [SIZE=16px][FONT=Ubuntu][COLOR=#ff0000][CENTER] [/CENTER][/COLOR][/FONT][/SIZE]
    [LEFT][SIZE=16px][FONT=Ubuntu][COLOR=#ff0000][SIZE=13px][FONT=Tahoma][COLOR=#141414] I dont know why I am getting this. I have checked the FTP_Username and FTP_Password in the config file. It matches what is in the Storage Management settings in the FOG web interface too.[/COLOR][/FONT][/SIZE][/COLOR][/FONT][/SIZE][/LEFT]
    [LEFT][SIZE=16px][FONT=Ubuntu][COLOR=#ff0000] [/COLOR][/FONT][/SIZE][/LEFT]
    [LEFT][SIZE=16px][FONT=Ubuntu][COLOR=#ff0000][SIZE=13px][FONT=Tahoma][COLOR=#141414]Any help is appreciated. Thank you.[/COLOR][/FONT][/SIZE][/COLOR][/FONT][/SIZE][/LEFT]



  • Alright, so I found the wiki and reset the password, but I am still getting the same error as above. Any other reasons why this would happen?


  • Moderator

    There is a wiki article about changing the password for the fog user.



  • I did not. I installed ubuntu, then downloaded and ran the fog installation. Is there a way to fix the fog user issue?


  • Moderator

    Usually this problem happens because you created a “fog” user on the system before installing FOG. Did you do this?



  • Ok, so I created a new ftp user called fogstorage. I changed all my settings in the correct places. Now I get this error.
    [SIZE=16px][FONT=Ubuntu][COLOR=#ff0000][CENTER]Failed to create deploy task[/CENTER][/COLOR][/FONT][/SIZE]
    [SIZE=16px][FONT=Ubuntu][COLOR=#ff0000][CENTER]FOGFTP: Failed to put file. Remote Path: /tftpboot/pxelinux.cfg/01-00-25-64-e2-1d-31, Local Path: /tmp/FOG7lPJwP, Error: ftp_put(): Could not create file.[/CENTER][/COLOR][/FONT][/SIZE]



  • I had a similar issue with my fog server when I moved it from a VM to a real box. The issue I had was that when uploading an image it would do the upload but not move it over to /images/. I found that changing the fogstorage user over to an account on the system that had access to the files via ftp worked. I had my password correct too but it just wouldnt take it for some reason.

    Anyway, I dont think there are any security vulnerabilities doing it this way, just hope this helps with your problem.


Log in to reply
 

395
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.