• Re: Permission Denied on Boot.php

    Hi, i add a reply on this topic because i have a similar problem and i don’t find a way to fix it.

    I have 13 computer, for 5 of them deployment works but for the others nothing work.

    Here a video of the problems


    I can send you others informations but i don’t know witch one ?

    i hope it’s not something big and just an mis-configuration of mine.


  • @sebastian-roth Well there is some news. So today some others computer who worked before make the same bug, some i relaunch the fog installer. On this computer thats work i havent found the time to test with the first computers so i let you know. But i don’t understand why it work this time and it doesn’t last time.

    Thanks for you help

  • @sebastian-roth Yes i’m sorry, i test it today, the second server is on an other place. I already try to running again the fog installer and that’s not working.

  • Moderator

    @btoffolon Well, in your other message you didn’t tell us about a second server and said that some PCs work and others don’t So my answer was targeting this situation. If it’s two servers and the clients on one work but not one the other it’s definitely a different issue. Most likely you can solve it by re-running the FOG installer.

  • @sebastian-roth

    I forget to said that the error come without lauching any task. I try to access to the fog menu without any task and i have the same error.

    I think it’s maybe on the fog configuration,I have two fog servers because à have two network link by VPN. I take the computer on my second server and i can access to fog without the error message.

    I will try two comparate the two server configuration.

  • Moderator

    @btoffolon Ok, so the output tells us that alle the files were created on the very same date and time. So you can dump me first theory that maybe the iPXE loaders don’t all have the certificate included.

    If you surely can PXE boot other machines then to me it looks like certain machines are just not able to handle the encrypted connection. I think we have had someone post a very weird issue like this in the forums some while ago but I can’t find it.

    Edit: Ok, doing some more research I found this:
    https://forums.fogproject.org/topic/15558/boot-php-denied-on-random-pcs (firmware update solved it)
    https://forums.fogproject.org/topic/15459/snp-efi-on-acer-travelmate-p2-tmp215-52-36qz-runs-on-no-buffer-space-available (the topic I had in the back of my mind but it’s a different error message altogether…)

  • @sebastian-roth
    Hi, thanks for your help.

    i will go see for the computer mode, meanwhile here the command you ask.

    root@FOG:~# ls -al /tftpboot
    total 6328
    drwxr-xr-x  5 fogproject root    4096 juin   7 13:42 .
    drwxr-xr-x 22 root       root    4096 nov.  25 14:48 ..
    drwxr-xr-x  4 fogproject root    4096 juin   7 13:42 10secdelay
    drwxr-xr-x  2 fogproject root    4096 juin   7 13:42 arm64-efi
    -rw-r-xr-x  1 fogproject root     868 nov.  25 14:57 boot.txt
    -rw-r-xr-x  1 fogproject root     460 nov.  25 14:57 default.ipxe
    drwxr-xr-x  2 fogproject root    4096 juin   7 13:42 i386-efi
    -rw-r-xr-x  1 fogproject root  252928 nov.  25 14:57 intel.efi
    -rw-r-xr-x  1 fogproject root  100240 nov.  25 14:57 intel.kkpxe
    -rw-r-xr-x  1 fogproject root  100288 nov.  25 14:57 intel.kpxe
    -rw-r-xr-x  1 fogproject root  100281 nov.  25 14:57 intel.pxe
    -rw-r-xr-x  1 fogproject root 1062400 nov.  25 14:57 ipxe.efi
    -rw-r-xr-x  1 fogproject root  901120 nov.  25 14:57 ipxe.iso
    -rw-r-xr-x  1 fogproject root  364288 nov.  25 14:57 ipxe.kkpxe
    -rw-r-xr-x  1 fogproject root  364336 nov.  25 14:57 ipxe.kpxe
    -rw-r-xr-x  1 fogproject root  363701 nov.  25 14:57 ipxe.krn
    -rw-r-xr-x  1 fogproject root  363701 nov.  25 14:57 ipxe.lkrn
    -rw-r-xr-x  1 fogproject root  364476 nov.  25 14:57 ipxe.pxe
    -rw-r-xr-x  1 fogproject root  409600 nov.  25 14:57 ipxe.usb
    -rw-r-xr-x  1 fogproject root   26140 nov.  25 14:57 memdisk
    -rw-r-xr-x  1 fogproject root  283136 nov.  25 14:57 ncm--ecm--axge.efi
    -rw-r-xr-x  1 fogproject root  250880 nov.  25 14:57 realtek.efi
    -rw-r-xr-x  1 fogproject root  100975 nov.  25 14:57 realtek.kkpxe
    -rw-r-xr-x  1 fogproject root  101023 nov.  25 14:57 realtek.kpxe
    -rw-r-xr-x  1 fogproject root  101040 nov.  25 14:57 realtek.pxe
    -rw-r-xr-x  1 fogproject root  250368 nov.  25 14:57 snp.efi
    -rw-r-xr-x  1 fogproject root  250368 nov.  25 14:57 snponly.efi
    -rw-r-xr-x  1 fogproject root   99686 nov.  25 14:57 undionly.kkpxe
    -rw-r-xr-x  1 fogproject root   99734 nov.  25 14:57 undionly.kpxe
    -rw-r-xr-x  1 fogproject root   99742 nov.  25 14:57 undionly.pxe
  • Moderator

    @btoffolon said:

    I have 13 computer, for 5 of them deployment works but for the others nothing work.

    Are the 5 working ones set to UEFI mode? That might explain what we see here.

    From the video I extracted the picture for others to make it easier:

    Pretty clear issue with the iPXE binary not being able to talk to the FOG server via HTTPS. Please run ls- al /tftpboot and post output here. Just want to see if all the binaries have the same timestamps.