FOG Across subnets



  • I am wondering if FOG can manage and service computers across subnet masks. I read the wiki and I understand that setting up the server to use proxyDHCP works on Ubuntu 10.04 and FOG .32. The only problem with that is that I’m using Ubuntu server 12.04LTS and FOG .32. I can get clients to boot to FOG that are on the same subnet, but machines on other subnets don’t boot. If it helps, we are ip addressing in the range of 172.16.x.x…



  • We are set up this way because each of our campuses has a different ip range and different domains and it is easier for us to have multiple DHCP servers that have smaller scopes and configurations than one server with large scopes and configurations.


  • Moderator

    Without an error code or some detailed symptoms, it’d be a wild guess, so I’ll avoid that.

    Can I ask why your network has a separate windows DHCP server for each subnet?



  • Yeah, then I have no idea what changed to make it start working. The scope options have been set since the beginning of installation and it didn’t work then, but it works now. Any ideas?


  • Moderator

    That setting is usually only needed if you are running storage node servers that need to connect back to the main FOG database. It has nothing to do with PXE boot. As far as I can recall, even during boot and execution of the scripts, there is no direct call to mysql because all the querying and udpates are done through web service calls over http.



  • I’ve actually got it working now. I set the scope options 66 & 67, but that alone didn’t help. The last thing I did before it worked was edit the the my.conf file in mysql to bind-address=(server ip) instead of bind-address=127.0.0.1… I don’t know if that fixed it, but it works now. Thank you for all your help though


  • Moderator

    Pick a test subnet, set the DHCP server up to have the option 66 and 67. pxe boot a client and post what happens. Do you get a tftp error? Does it time out? file not found? etc.



  • Our subnets can talk to each other. I was able to tftp the file boot file from our FOG server. I went ahead and unistalled the proxyDHCP service also. I am still not able to boot to it though


  • Moderator

    Can the subnets talk to each other using tftp and nfs? You might try to see if you can tftp get the pxe boot file from a client on another submit, manually from the command line.

    In my installation, we use proxyDHCP, but only because we have some problem-child clients that will not boot PXE without it, no matter what subnet they are in. We use one DHCP server to service six subnets, and have IP-HELPER/DHCP-RELAY configured on the router that handles the VLANs.

    If you can tftp from a client on another subnet back to the FOG server, that’s a start.



  • We use Windows servers for DHCP. Machines that are on the same subnet as FOG boot just fine, but other machines on different subnets don’t boot. The DHCP server that maintains the subnet that FOG is on has its scope options 66 & 67 set like they should and that entire subnet works. Our other subnets (maintained by different DHCP servers) don’t work. I set the scope options on another subnet’s DHCP server and that didn’t work. If you need some more details let me know


  • Moderator

    You don’t have to use proxyDHCP to service multiple subnets. The article on the wiki is meant to show you how to service multiple subnets IF you are using proxyDHCP.

    FOG by default will service multiple subnets. It depends on your switch/router configurations. Is FOG your DHCP server or do you use an appliance or Windows server?



  • Okay. I did some more reading on the wiki and throughout the internet. I understand that in the proxyDHCP configurations you can insert a subnet mask that includes all of the subnets. I don’t particularly want to do this though. Just a thought, is there a way to just insert specific subnets? Our broadest subnet mask is 255.255.0.0


Log in to reply
 

368
Online

38724
Users

10553
Topics

99875
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.