EFI PXE Boot Setup and Questions


  • I have had a Fog server setup and configured for the last 6 years, and it has ran pretty much flawslessly for most of that time. I have had the most friendly setup that fog can use, with Dell 7020’s and 9010’s, with legacy boot enabled. PXE boot to fog, or deploy the image from the console, piece of cake.

    Recently we switched to HP, and are looking to go fully UEFI. Created a test vlan for this and added the same DHCP options on 66 and 67 I have always had, and added the vendor class rule EFI found HERE (PXEClient:Arch:00007). Currently, I can’t even get legacy to boot to pxe on this test vlan, much less EFI.

    So a few basic questions first. Do I need to bounce my fog server before this will work (hasn’t been rebooted in 2 or 3 years)? For option 67, do I continue to use undionly.kpxe, or should I use ipxe.efi? Is there somewhere on the forums that has a complete list of what to put as the vendor class settings? PXEClient:Arch:00007 is the only vendor class settings that I added.

    Just to get this to working, could I remove all of the vendor class setting rules, and change the boot file to ipxe.efi, and just use the vlan for imaging the new PCs?

    Any assistance here is greatly appreciated.


  • @george1421 well, I am excited to say that it is working. I literally just readded what was already added, and re-tested. Could have been gremlins or lack of sleep, whatever the case, I am about to capture my image, and do a test deploy. I will ping you back shortly and you can close this as solved I do believe.

    Thank you so much for the assistance. Ping me anytime you need a tester.

  • Moderator

    @mike_ said in EFI PXE Boot Setup and Questions:

    Should 00007 and 00009 be the only vendor classes that I need to add now?

    Yes if you have only 64bit uefi machines those are all that is required. I might also suggest that you when you create and don’t forget to ACTIVATE the policies on your dhcp scope, than you only set dhcp option 67 (the instructions say to set both 66 and 67. Setting dhcp option 66 in the policy is only needed if you have a different boot server than your main fog server. If you don’t create a dhcp option 66 in your policy then the default one is used.


  • @george1421 Hi George. I removed the vendor class rules, and tested legacy pxe boot, and it is working.

    Should 00007 and 00009 be the only vendor classes that I need to add now?

    The PCs that will be UEFI booting are HP Elitedesk 800 G2 if it matters?

    thanks for your assistance here btw.


  • @george1421 Let me add Arch 9 and test this morning and I will ping you back. Thank you very much, I appreciate the assist.

  • Moderator

    @mike_ said in EFI PXE Boot Setup and Questions:

    Do you see any reason why I can’t use one vlan for EFI boot, and my other already configured vlans for bios? Then when I get the refresh completed, change the others to EFI?

    Well I guess there is no reason why you can’t do it that way. But if you have the bios/uefi coexistence setup correctly it will not matter because the dhcp server will send out the right file based on what the pxe booting computer says it is.

    If you want to debug this vlan issue where it won’t boot we can do that if you have a witness (second computer) with wireshark loaded. I can give you instructions if you want to go that route.


  • @george1421 said in EFI PXE Boot Setup and Questions:

    There are not changes you need to do the fog server, since the issue is with your dhcp server not FOG at this point.

    thanks George. Yes I only have one fog sever

    Do you see any reason why I can’t use one vlan for EFI boot, and my other already configured vlans for bios? Then when I get the refresh completed, change the others to EFI?

  • Moderator

    @mike_ First you followed the right guide.

    For bios, set the default entries (policy == none). dhcp option 66 == ip address of fog. dhcp option 67 == undionly,kpxe. That should boot a bios computer without fail.

    Now comes the uefi systems, you need to create a policy for both arch 7 AND arch 9. Both are 64 bit uefi. I know the instructions say to set dhcp option 66 in the policy, but you can ignore it if you only have one 1 fog server. Just set dhcp option 67 in both policies.

    There are not changes you need to do the fog server, since the issue is with your dhcp server not FOG at this point.

360
Online

9.0k
Users

15.6k
Topics

145.0k
Posts