PXE Boot Error - Disk Drive not found



  • Hi Guys,

    Having issues with PXE Booting. Could somebody please push me in the right direction.

    I am new to this btw. I have attached the error message.

    fogerror.JPG


  • Senior Developer

    I know this thread is slightly older, but my latest of kernels seems to work with VMWare, and many others I’m sure, SCSI natively. No more having to change to Paravirtualized or anything to upload the image, to reset to the one windows needed to operate properly. Hopefully this helps. It should come with FOG 0.33b and if you’re not feeling good about going down the beta road, try downloading the latest one at: https://mastacontrola.com/fogboot/kernel/bzImage


  • Moderator

    http://www.fogproject.org/wiki/index.php/FOG_with_VMWare

    a quick search on the wiki for “vmware”



  • For future reference I think the scsi issue MIGHT be the client side kernel. I dont know if the standard kernel you get with the fog install for the network boot is scsi enabled or not. I could be wrong but thats the first thing that pops into my mind. Perhaps if a developer sees this they could clarify?

    I also know that you can replace those kernels with different ones… I’m sure there’s a solution to the problem for anyone wanting to do this any how.



  • Thanks again for all the help. I had switched off the firewall from before. Will start a new thread.



  • I’ve never used snap-ins, you’re probably better off starting a new thread to attract the attention of those who have.
    Just guessing, could it be a host firewall issue?



  • Well with a Physical machine that isn’t SCSI it worked fine. Thank you for that, honestly been banging my head against the wall for ages.

    Suppose you couldn’t help me with one more issue, I can’t seem to push out Snap-ins? It says in progress but seems to be taking a very very long time? I can’t see anything at the PC end.



  • I’m far from an expert on the subject, but it could be an issue with the host kernel not containing the drivers to support the SCSI hardware. Its possible to build custom kernels containing other drivers but its not something I’ve ever needed to do or whether SCSI devices would actually work.



  • Got a physical machine and will see if it works with that. Is there a SCSI solution?



  • Does it need to be a SCSI HDD for any particular reason? I’ve never actually tried any SCSI drives with FOG but I suspect you’ll have more luck with a SATA/IDE drive.



  • Hi Moss,

    IT’s a SCSI HDD



  • What type of virtual hard drive are you using? IDE/SATA/SCSI?



  • VM…also a windows 7 32 bit installation. Don’t know if that makes a difference? Any help would be appreciated. We are looking to use FOG to roll out Win7 across our network



  • Is this is a physical or virtual machine you’re trying to image?


Log in to reply
 

465
Online

38923
Users

10690
Topics

101416
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.