Fog Image Capture Error Permision Denied.


  • I have a storage node that is using an nfs share on truenas setup in fog 1.5.9. I have also mounted the share on the fog server and mounted it in /media/s23images. /images is still in the default node. When i try to capture an image using the nfs node fog tries to mount /media/s23images to /images and gets a permission denied error? How can i just get this to capture to /media/s23images?


  • https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_NFS
    Creating & verifying .mntcheck files
    .mntcheck is a hidden and empty file that a FOG client uses during image capture and image download/deployment to verify an NFS share is mounted correctly.

    To create these files, on the FOG server:

    touch /images/.mntcheck
    touch /images/dev/.mntcheck
    Verify these files with:

    ls -laR /images | grep .mntcheck

  • Moderator

    @bsawyers Well there are a number of reasons why this fails.

    The first thing to check is to see if squash root is enabled. The FOS Linux engine (what runs on the target computer to capture/deploy images) runs as root. This in a way is not an ideal situation. If your nfs server is configured to reject root connections that might cause a problem.

    It could also be how you have your storage node configuration setup in the web ui.

    How I would go about debugging this is to setup a debug capture/deploy (tick the debug checkbox before you hit the schedule task button) in the web ui. That will drop you to a linux prompt on the target computer. From there try to mount your truenas nfs share. If you can get it to work from there then its just duplicating the configuration in the web ui.

272
Online

8.7k
Users

15.4k
Topics

144.1k
Posts