Install/update your database schema" URL just goes to blank FOG UI .


  • When i run the installer (i have enabled https)
    it tells me to validate that the database install / update your database schema by going to the url.

    When i go there and click through the ssl untrusted errors (which are all valid)
    the page is blank as if nothing has loaded

    I go back to the cli and hit enter to continue to get past the install issue

    cat /root/fogproject/bin/error_logs/fog_error_1.5.9.log

    it lists httpd.service starting loaded / active
    php-fpm.servive loaded / active

    Sep 08 14:55:56 ssvpfog01l1l.idm.lhi.com systemd[1]: Starting The PHP FastCGI Process Manager…
    Sep 08 14:55:56 ssvpfog01l1l.idm.lhi.com systemd[1]: Started The PHP FastCGI Process Manager.
    ERROR 1146 (42S02) at line 1: Table ‘fog.globalSettings’ doesn’t exist

    not sure what else to look at?

    i have validated that the services have started as expected. but the page isn’t loading.


  • @llightfoot

    When I inspect the page and go tot he network tab hit refresh @
    https://10.33.250.5/fog/management/

    It gets a server 500 response from /fog/management/
    and the second thing it attempts to load is favicon.ico which is a 404 error.

    L
    llightfoot
    about 5 hours ago

    I should give some more specifics.

    This is a first server build on physical hardware.
    Rhel 7
    I utilized the rhel 7 install instructions
    I did not use any specialized command line options when kicking off the bash script to install fog.
    I did disable selinux
    I did disable firewall
    I can access the login page after passing through the ssl error but there is nothing to log into.


  • This post is deleted!

  • The problem after a lot of investigation was a function that was only available in php 5.6. and later wasn’t available because the redhat repo that was available to the host only allowed 5.4.
    the installer tried using 3 remi repo’s remi-php72, remi, and remi-safe to get access to the newer version of php.

    There was an error in the logs that sent me down the right path in a round about way.
    cat /root/fogproject/bin/error_logs/fog_error_1.5.9.log

    the errors read this:.
    remi-release-7.9-2.el7.remi.noarch
    No such command: config-manager. Please use /bin/dnf --help
    It could be a DNF plugin command, try: “dnf install ‘dnf-command(config-manager)’”
    No such command: config-manager. Please use /bin/dnf --help
    It could be a DNF plugin command, try: “dnf install ‘dnf-command(config-manager)’”
    No such command: config-manager. Please use /bin/dnf --help
    It could be a DNF plugin command, try: “dnf install ‘dnf-command(config-manager)’”

    since i was doing this install on 2 servers simultaneously i was able to test it both ways
    run that command - dnf install ‘dnf-command(config-manager)’

    which was able to execute and enable those 3rd party repos and get the packages installed upon re-running the .installfog.sh

    Ultimately i added those packages to my satellite server and made it available.

    I believe a true fix would be to create a switch option for the install script that turns on dnf config-manager. Ultimately we only want it to be pulled down from our repo on our satellite server, but it would have been nice to be able to control it during the install. / upgrade process in the future.

  • Senior Developer

    @llightfoot said in Install/update your database schema" URL just goes to blank FOG UI .:

    It gets a server 500 response from

    Please check Apache and PHP-FPM logs - see my signature.


  • This post is deleted!

  • This post is deleted!

260
Online

8.7k
Users

15.4k
Topics

144.1k
Posts