• I followed the instructions here; https://forums.fogproject.org/topic/10944/using-fog-to-pxe-boot-into-your-favorite-installer-images for Hirens 1.0.1 and all worked great or so it seemed, it seems to work perfectly, loads up the wimboot, bcd, boot.sdi, BOOTMGR and then the boot.wim, but after it gets to 100% and it seems like it would start to boot into Hirens, instead it just goes back to the main Fog Menu, except its all black and white instead of the normal looking menu, anyone have any ideas as to why it might be doing that? Any Help would be appreciated. Thanks


  • Hi

    I can confirm also that Hirens boot cd it loads but i can not see the programs at all.
    The apps of Hirens boot cd is not there.


  • @mikr Thanks, I managed to get it working on UEFI with your settings, but my problems is, that there aren’t all the apps after it boots succesfully. Only those which have a link to Program files. Those in the Programs folder in the ISO, aren’t available. For. ex: only HDDScan and Test Disk are available in the HDD Diagnostic Tools. Any ideea how to solve this?


  • I managed to get Hiren BootCD 1.0.2 working on UEFI (Only tested in Hyper-V 2019 Gen. 2) by using the following config:

    set tftp-path tftp://${fog-ip}
    set http-path http://${fog-ip}/images/tools/hbcd102
    kernel ${tftp-path}/win/wimboot gui
    imgfetch --name bootmgr.exe ${http-path}/bootmgr.exe bootmgr.exe
    imgfetch --name bootx64.efi ${http-path}/efi/boot/bootx64.efi bootx64.efi
    imgfetch --name BCD ${http-path}/boot/bcd BCD
    imgfetch --name boot.sdi ${http-path}/boot/boot.sdi boot.sdi
    imgfetch --name boot.wim ${http-path}/sources/boot.wim boot.wim
    boot || goto MENU
    

    The key was to add:

    imgfetch --name bootx64.efi ${http-path}/efi/boot/bootx64.efi bootx64.efi
    

  • @george1421 said in Hiren BootCD 1.0.2:

    imgfetch --name boot.wim http://${fog-ip}/boot.wim boot.wim

    Well it loads ALOT faster, but still does the same thing.

  • Moderator

    @garthhess Ok lets try sending that wim file via http not tftp. It might be timing out.

    for RHEL/Centos cp /tftpboot/os/Hiren101/boot.wim /var/www/html
    for Debian/Ubuntu variants cp /tftpboot/os/Hiren101/boot.wim /var/www

    Now lets update this line in the ipxe menu configuration.

    imgfetch --name boot.wim ${pe-path}/boot.wim boot.wim
    

    to this

    imgfetch --name boot.wim http://${fog-ip}/boot.wim boot.wim
    

    Understand I really didn’t think this through, but it should be pretty close to actually working. The apache server is much better suited to serve out larger files than the tftp server.


  • @george1421 said in Hiren BootCD 1.0.2:

    wimboot 2.7.3

    I replaced the wimboot file from the wimboot-2.7.3.zip download, does the same thing, also, I’m booting UEFI with the ipxe.efi if that makes any difference?

  • Moderator

    @garthhess I need to update that tutorial for hirens. It seems like they changed the structure of the wim file since the tutorial was created.

    Take a look at this post. I was able to capture the error: https://forums.fogproject.org/post/144293

    The root of the issue is you need the latest version of wimboot 2.7.3 that understands the compression of the wim file.

    Now you might still get an error about bootmgr.exe. If you do I have a fix for that too.

246
Online

9.9k
Users

16.2k
Topics

149.0k
Posts