mysql not starting when trying to install 2nd time


  • Hi there,

    i had a failed first time install becuase p5 by archiware uses port 9000.

    i’ve since moved that port and tried to install again and got an error saying mysql couldn’t start

    attached is the command line runinng the install script

    here’s the status of mysql service
    [root@backup bin]# systemctl status mysql
    ● mariadb.service - MariaDB database server
    Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled)
    Active: failed (Result: exit-code) since Mon 2021-07-19 17:33:55 BST; 2min 41s ago
    Process: 47476 ExecStartPre=/usr/libexec/mariadb-prepare-db-dir %n (code=exited, status=1/FAILURE)

    Jul 19 17:33:55 backup systemd[1]: Starting MariaDB database server…
    Jul 19 17:33:55 backup mariadb-prepare-db-dir[47476]: The directory /var/log/mariadb does not exist.
    Jul 19 17:33:55 backup systemd[1]: mariadb.service: control process exited, code=exited status=1
    Jul 19 17:33:55 backup systemd[1]: Failed to start MariaDB database server.
    Jul 19 17:33:55 backup systemd[1]: Unit mariadb.service entered failed state.
    Jul 19 17:33:55 backup systemd[1]: mariadb.service failed.[0_1626712795281_install log01](Uploading 0%)

    Here’s the install log

    install log01.txt

  • Senior Developer

    @chris_unit said in mysql not starting when trying to install 2nd time:

    did you install on 7.2?

    I haven’t. Somehow thought this was a typo when you first mentioned version 7.2. Quoting from: https://mirrors.xtom.de/centos/7.2.1511/readme

    This directory (and version of CentOS) is deprecated. For normal users,
    you should use /7/ and not /7.2.1511/ in your path. Please see this FAQ
    concerning the CentOS release scheme:

    https://wiki.centos.org/FAQ/General

    If you know what you are doing, and absolutely want to remain at the 7.2.1511
    level, go to http://vault.centos.org/ for packages.

    Please keep in mind that 7.2.1511 no longer gets any updates, nor
    any security fix’s.

    Sorry but we don’t have enough people to work on FOG for it to support officially deprecated OS versions.


  • I’ve given up trying to get this installed on this particular server

    i’m now running fog on a vm


  • @sebastian-roth said in mysql not starting when trying to install 2nd time:

    /opt/fog/.fogsettings

    Hi there

    everything is set to default settings i dont make any custom changes.

    did you install on 7.2?

    unforutnatly /opt/fog/.fogsettings doesn’t exist

  • Senior Developer

    @chris_unit Looking at Wayne’s automated Test install results I see CentOS 7 works just fine: http://fogtesting.theworkmans.us/

    So I guess there is something special with your setup. Did you manually add an external repository for PHP packages?

    Or do you have an existing settings file in /opt/fog/.fogsettings? If so, then post the contents of this file here in the forums.


  • Hi there

    it’s centos 7.2 and latest version of fog.

    our backup software must use multicasting but ive since moved that from the default port so that issue is resolved

    the issue now is the php issue during install

  • Senior Developer

    @chris_unit said in mysql not starting when trying to install 2nd time:

    i had a failed first time install becuase p5 by archiware uses port 9000.

    I am not sure I get what you mean by that!?

    What Linux OS and version do you use?


  • I"ve manged to get a bit further by removing mysql so that it could be installed fresh again

    now i have an issue with php?

     * Setting up fogproject user..................................Skipped
     * Locking fogproject as a system account......................OK
     * Setting up fogproject password..............................OK
     * Stopping FOGMulticastManager.service Service................OK
     * Stopping FOGImageReplicator.service Service.................OK
     * Stopping FOGSnapinReplicator.service Service................OK
     * Stopping FOGScheduler.service Service.......................OK
     * Stopping FOGPingHosts.service Service.......................OK
     * Stopping FOGSnapinHash.service Service......................OK
     * Stopping FOGImageSize.service Service.......................OK
     * Setting up and starting MySQL...............................OK
     * Setting up MySQL user and database..........................
       The installer detected a blank database *root* password. This
       is very common on a new install or if you upgrade from any
       version of FOG before 1.5.8. To improve overall security we ask
       you to supply an appropriate database *root* password now.
    
       NOTICE: Make sure you choose a good password but also one
       you can remember or use a password manager to store it.
       The installer won't store the given password in any place
       and it will be lost right after the installer finishes!
    
       Please enter a new database *root* password to be set:
    
    OK
     * Backing up user reports.....................................Done
     * Stopping web service........................................OK
     * Setting up Apache and PHP files.............................Failed
       ###########################################
       #                                         #
       #      PHP Failed to install properly     #
       #                                         #
       ###########################################
    
       Could not find /etc/php.ini!
    

291
Online

8.8k
Users

15.5k
Topics

144.5k
Posts