Dell Optiplex 3020M does not get past pxe over IPV4


  • I have a few dell optiplex 3020M SFF. I cannot get the unit to do a quick registration. BIOS is at A15 level for the 3020.

    I am able to image a dell optiplex 3050 with no issues.
    I can push and pull an image from the 3050.
    I am running fog version 1.5.8 using the latest TFTP kernel 5.10.34


  • Thanks everyone for the input…finally got it to work. I tried snponly.efi no go.

    This is the combination that worked.
    BIOS A15
    Legacy mode is on
    undionly.kpxe on the advanced DHCP option

  • Senior Developer

    @unco Beside checking secure boot you might also try setting a different iPXE binary in your DHCP server. Default for UEFI is ipxe.efi but you can try snponly.efi as well.

    Other steps are updating the UEFI firmware and searching the forums for 3020 or 3020M to see if other people had an issue with that hardware as well.

  • Moderator

    @unco Hmmm that’s not a fog or ipxe menu.

    My first reaction is secure boot disabled on this computer?

    During a pxe boot, the ipxe boot loader would be transferred to the target computer, but if secure boot is enabled ipxe won’t be able to load so it may return back to the uefi boot manager (what I think your text is representing). You should at least see the iPXE menu.


  • @george1421

    I wish there were errors, the 3020 just goes back to the boot screen with the following options

    UEFI: PNY CS900 240GB SSD
    UEFI: IP6 Realtek PCIe GBE Family Controller (Ipv6)
    UEFI: IP4 Realtek PCIe GBE Family Controller (Ipv4)

  • Moderator

    @unco said in Dell Optiplex 3020M does not get past pxe over IPV4:

    I cannot get the unit to do a quick registration.

    What errors do you see? A clear picture of the error taken with a mobile phone would help us set the context of the error.

292
Online

8.8k
Users

15.5k
Topics

144.5k
Posts