Prevent Windows 10 to change itself UEFI BIOS boot order after deploying


  • Before deploying Windows 10 Pro x64 to PC, UEFI BIOS boot order is:
    #1 - UEFI: PXE IPv4 Intel I211 Gigabit Network Connection
    #2 - Windows Boot Manager
    After deploying Windows 10 Pro x64 to PC, Windows 10 once changes UEFI BIOS boot order itself to:
    #1 - Windows Boot Manager
    #2 - UEFI: PXE IPv4 Intel I211 Gigabit Network Connection
    How could I prevent Windows 10 to change itself UEFI BIOS boot order after deploying?

    Some information:
    I experience such problem on Asrock-X570 Phantom Gaming4, MSI Z370-A PRO, MSI H270 PC MATE, MSI H170A PC MATE motherboards. But MSI Z77A-G43 motherboard is OK, Windows 10 doesn’t change itself UEFI BIOS boot order after deploying.

    Fog settings:
    EFI BOOT EXIT TYPE - REFIND_EFI
    BOOT EXIT TYPE - SANBOOT

    Windows image: WIndows 10 20h2 Pro 64 bit with GPT partition tables

  • Senior Developer

    @nockdown You might check the UEFI/BIOS firmware settings to see if you can disable the automatic boot order switch. Or maybe even contact Asrock to see what they can offer.


  • @sebastian-roth ,

    Thank you very much for reply!

  • Senior Developer

    @nockdown We have had a few reports of this behaviour in the past. FOG does not touch the UEFI entries nor the boot order. Seems like some UEFI firmware is trying to be smart - changing boot order and sometimes even adding of entries automatically. Not much we can to about this in FOG, I am afraid.

390
Online

8.8k
Users

15.5k
Topics

144.5k
Posts