SOLVED Imaging FZ-G1 MK1 with Docking Station (Realtek RTL8152B)

  • Hi Guys,

    I have recently started using FOG and absolutely loving it thus far.

    I’ve hit the first hurdle that I have been unable to resolve by reading through existing threads.

    I am imaging up 120 Panasonic FZ-G1 MK1 machines using their supported docking station which uses a Realtek RTL8152B nic.

    Typically with other FZ-G1 models (the newer machines) i would use a USB ethernet adaptor but the MK1 machines don’t appear to detect these in the BIOS.

    I am running version: 1.5.9
    DNSMasq on a Ubuntu 20.04 host

    If I boot via legacy I receive a “No configuration methods succeeded” whilst using undionly.kkpxe (i tried others this proceeded the furthest). I have fully disabled spanning tree on my network for the time being and it hasn’t made a difference unfortunatly.

    When booting using UEFI i hit a “ipxe initialising devices…” and no further progress is made.

    Can anyone provide some advice? I would prefer to multicast deploy these machines instead of manually deploying via Acronis or Clonezilla.

  • Okay so after George was kind enough to assist me with building a USB deployment method (which works great)

    I have played around with the FZ-G1 on a docking station and I have been able to get these to PXE boot directly using a UEFI method.

    It seems for some insane reason when selecting the IPV4 PXE option in the BIOS under boot override (which is 99% of the time the method I have used). It will become stuck at"ipxe initialising devices…"

    If you specify LAN as the primary boot device and allow the machine to boot organically, it works… go figure?

    So anyway this is now solved! Thanks for your help guys.

  • Moderator

    @zedx Here is the instructions for building the FOS Linux USB boot method.

    Also look at the FOG Forum chat for a few additional hints.

  • Thanks for getting back to me Sebastian.

    Unfortunately, I am imaging a custom FZ-G1 build in this instance, and the fw updates are not supported. This isn’t always the case but the current batch of ~100 machines I am imaging are at all the same PN. I suspect they were ordered for a large customer in bulk.

    In any event, I have tried the other EFI binaries in the past. I’ll put some time into trying them again this week and report what occurs.

    Thanks, George! I did look at the FOG Linux method but the threads you had posted referenced a binary creation tool that seemed to have been removed (domain didn’t exist If memory serves)

    Unicast imaging would be more than fine. I generally stack them up in a pile and boot them into FOG using the volume and windows key buttons on the tablet. So selecting a deployment via unicast would be fine. I don’t mind if it takes a while to deploy, to be honest, I can just kick off a lot of 10 at a time. I’m more concerned with the human time factor it takes to image them using other methods.

    I’ll have a read through the Lenovo “ThinkBook 15 G2 ITL not PXE booting” thread too!

  • Moderator

    @zedx said in Imaging FZ-G1 MK1 with Docking Station (Realtek RTL8152B):

    Panasonic FZ-G1 MK1 machines using their supported docking station

    I think I have a few of these on my campus. Let me check to see what we need to get them to pxe boot. Off the top of my head I would say to make sure the firmware is up to date on the system. They are pretty old to start with ~5 years if I remember correctly.

    If we can’t get them to boot into iPXE (needed for multicasting) we can probably get them to boot into FOS Linux but usb booting into FOS only supports unicast imaging.

  • Senior Developer

    @zedx First I suggest you check if there is an update of the firmware for those devices available. Installing a firmware update can help.

    You can also try different iPXE binaries for UEFI to see if it make any difference. Instead of the default ipxe.efi try snponly.efi and snp.efi.

    If that doesn’t help you can try compiling iPXE from the very latest source code in hope of those fixing the issue. See my post here on how to do that: