• We updated from 1.5.8 to 1.5.9 (CentOS7; first did yum update -y, then verified GIT, and then FOG). Ended up extracting the gz file and then running the installfog.sh. Appeared everything went smooth, but when we fired up our Master PC to pull latest image, we got the attached errors. One thing of note, in the FOG Configuration, under the FOG Version Information, it did appear weird as it indicated 1.5.9, but it said it was not the latest version and none of the Latest had information. Do we need to update IPXE as well, or any ideas what might be the issue? Some research of the error indicated the images were corrupt, but when we rolled the server back to the snapshot of 1.5.8, everything was fine.
    ipxe error 1.jpg

  • Senior Developer

    @wkratky Please run the following commands and post all output here:

    ls -al /var/www
    grep docroot /opt/fog/.fogsettings
    find /etc -type f -exec grep DocumentRoot {} /dev/null \;

  • I ran those ls -a and md5sum commands, and it says no such file or directory exists for both, which I confirmed in connecting to the server via WinSCP. See attached for the information from the link you provided. ltops333.txt

  • Thank you for the reply. Sorry for the delay, I got pulled into other projects over the time span. Hoping to crave out a window tomorrow or Friday to give this another shot.

  • Senior Developer

    @wkratky I just did a quick test, CentOS 7, installed 1.5.8, registered a host, captured an image, then updated to 1.5.9 and was able to PXE boot and capture just fine. So it does not seem to be a general issue.

    Any chance the server was running out of disk space and that caused the binaries to be corrupted?

    From what we see in the picture it looks like the FOS Linux kernel or init cannot be loaded/started properly. So let’s check those files first. If you jumped back to the 1.5.8 snapshot you want to download 1.5.9 again and upgrade. Then schedule a capture task and try again. If you end up in the same error screen (really the exact same, not just kind of!) then run the following commands on your FOG server console and post output here:

    ls -al /var/www/html/fog/service/ipxe/bzImage* /var/www/html/fog/service/ipxe/init*
    md5sum /var/www/html/fog/service/ipxe/bzImage* /var/www/html/fog/service/ipxe/init*

    For reference I post the MD5 sums of the binaries I have from my 1.5.9 test install/update system:

    d1d94f4093fb610c29df77e2fb834352  /var/www/html/fog/service/ipxe/bzImage
    e35fbd4a266c831d6cfe183c456df78b  /var/www/html/fog/service/ipxe/bzImage32
    00e5b2219d6bd58387ee51302c4dc2c5  /var/www/html/fog/service/ipxe/init_32.xz
    d00fcf0f5f4ea8175142b12148e7f1de  /var/www/html/fog/service/ipxe/init.xz

    If the files all look fine and the MD5 sums match you want to check to iPXE boot code. Open this URL in your normal browser on any PC in your network that can reach the FOG server - use the FOG server IP as well as the MAC address of the host you want to capture from - post the text content you get in the browser window here in the forums: