No Subnet Declaration for virbr0 After Upgrade to 1.5.9


  • Fogserver is a VM in Synology Virtual Machine Manager and tagged to a VLAN (22)

    Message:

    No subnet declaration for virbr0 (192.168.122.1). Ignoring requests on virbro. If this is not what you want, please write a subnet declaration in your dhcpd.conf file for the network segment to which interface virbr0 is attached.
    

    Here’s the output of ip a s

    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host 
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 02:11:32:24:8f:86 brd ff:ff:ff:ff:ff:ff
        inet 192.168.22.11/24 brd 192.168.22.255 scope global noprefixroute eth0
           valid_lft forever preferred_lft forever
        inet6 fe80::9db3:f0a1:fdc2:e7fc/64 scope link noprefixroute 
           valid_lft forever preferred_lft forever
    3: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
        link/ether 52:54:00:a0:be:be brd ff:ff:ff:ff:ff:ff
        inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
           valid_lft forever preferred_lft forever
    4: virbr0-nic: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast master virbr0 state DOWN group default qlen 1000
        link/ether 52:54:00:a0:be:be brd ff:ff:ff:ff:ff:ff
    

    and content of /etc/dhcp/dhcpd.conf

    # DHCP Server Configuration file\n#see /usr/share/doc/dhcp*/dhcpd.conf.sample
    # This file was created by FOG
    #Definition of PXE-specific options
    # Code 1: Multicast IP Address of bootfile
    # Code 2: UDP Port that client should monitor for MTFTP Responses
    # Code 3: UDP Port that MTFTP servers are using to listen for MTFTP requests
    # Code 4: Number of seconds a client must listen for activity before trying
    #         to start a new MTFTP transfer
    # Code 5: Number of seconds a client must listen before trying to restart
    #         a MTFTP transfer
    option space PXE;
    option PXE.mtftp-ip code 1 = ip-address;
    option PXE.mtftp-cport code 2 = unsigned integer 16;
    option PXE.mtftp-sport code 3 = unsigned integer 16;
    option PXE.mtftp-tmout code 4 = unsigned integer 8;
    option PXE.mtftp-delay code 5 = unsigned integer 8;
    option arch code 93 = unsigned integer 16;
    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    # Specify subnet of ether device you do NOT want service.
    # For systems with two or more ethernet devices.
    # subnet 136.165.0.0 netmask 255.255.0.0 {}
    subnet 192.168.22.0 netmask 255.255.255.0{
        option subnet-mask 255.255.255.0;
        range dynamic-bootp 192.168.22.10 192.168.22.254;
        default-lease-time 21600;
        max-lease-time 43200;
        option routers 192.168.22.11;
        option domain-name-servers 192.168.22.1;
        next-server 192.168.22.11;
        class "Legacy" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00000";
            filename "undionly.kkpxe";
        }
        class "UEFI-32-2" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00002";
            filename "i386-efi/ipxe.efi";
        }
        class "UEFI-32-1" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00006";
            filename "i386-efi/ipxe.efi";
        }
        class "UEFI-64-1" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00007";
            filename "ipxe.efi";
        }
        class "UEFI-64-2" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00008";
            filename "ipxe.efi";
        }
        class "UEFI-64-3" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00009";
            filename "ipxe.efi";
        }
        class "SURFACE-PRO-4" {
            match if substring(option vendor-class-identifier, 0, 32) = "PXEClient:Arch:00007:UNDI:003016";
            filename "ipxe.efi";
        }
        class "Apple-Intel-Netboot" {
            match if substring(option vendor-class-identifier, 0, 14) = "AAPLBSDPC/i386";
            option dhcp-parameter-request-list 1,3,17,43,60;
            if (option dhcp-message-type = 8) {
                option vendor-class-identifier "AAPLBSDPC";
                if (substring(option vendor-encapsulated-options, 0, 3) = 01:01:01) {
                    # BSDP List
                    option vendor-encapsulated-options 01:01:01:04:02:80:00:07:04:81:00:05:2a:09:0D:81:00:05:2a:08:69:50:58:45:2d:46:4f:47;
                    filename "ipxe.efi";
                }
            }
        }
    }
    

  • @sebastian-roth Ahh, I didn’t see that either. Okay, so in DHCP I changed the router to 192.168.22.1 and range starting IP to .20

    In fogsettings, I changed both routeraddress and plain router from 192.168.22.11 to 22.1

    The test client gets online just fine now.

    Thank you again, Sebastian!

  • Senior Developer

    @SCavender Ahh, I didn’t notice the gateway (in DHCP) is set to your FOG server IP 192.168.22.11 when looking at the dhcpd.conf. Are you sure this is what you want? From what you said so far I would think you want the router to be 192.168.22.1.

    If your FOG server is meant to be a gateway it needs things like IP forwarding in the kernel enabled and iptables rules to pass packets through. Not something we provide with the FOG installer.

    While looking at the dhcpd.conf once again I also notice that you might wand to change the line range dynamic-bootp 192.168.22.10 192.168.22.254; because the range starts at 10 but your FOG server is at 11. Make it start at 20 for example to prevent from duplicate IP issues.

    Make sure you also change the values in /opt/fog/.fogsettings so the installer won’t reset things on the next upgrade!

    After changing the config you need to restart the DHCP service or your FOG server altogether.


  • Senior Developer

    @SCavender When you boot up a client, please run ipconfig /all in Windows CMD, take a picture and post here.

    Just want to see if it receives the DNS server information from the DHCP or not.


  • @sebastian-roth said in No Subnet Declaration for virbr0 After Upgrade to 1.5.9:

    Does this gateway provide DNS as well? Either as a DNS service or by relaying the DNS queries to an upstream DNS server?

    It must be, because this Fogserver instance is more than 2 years in production and has always worked great. Before upgrading to 1.5.9, the Fogserver and DHCP clients under it had internet access. After the upgrade, the Fogserver gets internet access/resolves webpages while the DHCP clients under it get LAN with “no internet access” though they can ping external sites.

    I just rebooted everything and there’s still no resolution.

  • Senior Developer

    @scavender said in No Subnet Declaration for virbr0 After Upgrade to 1.5.9:

    192.168.22.1 is the Gateway IP/Subnet for the VLAN 22

    Does this gateway provide DNS as well? Either as a DNS service or by relaying the DNS queries to an upstream DNS server?


  • @sebastian-roth 192.168.22.1 is the Gateway IP/Subnet for the VLAN 22 this Fogserver is connected to. The main Gateway IP/Subnet/Name Server is 192.168.1.1.

    The Fogserver surfs the web just fine, though DHCP clients don’t.

    eth0 DNS address is set to Automatic.

  • Senior Developer

    @scavender said in No Subnet Declaration for virbr0 After Upgrade to 1.5.9:

    Yes, I am using eth0 and DHCP works great. The problem is the clients don’t have internet access. They can ping external sites but webpages don’t load/resolve.

    Sounds like a DNS issue. In the DHCP service config you have option domain-name-servers 192.168.22.1; - is this the correct DNS server in this subnet?


  • @sebastian-roth Yes, I am using eth0 and DHCP works great. The problem is the clients don’t have internet access. They can ping external sites but webpages don’t load/resolve.

    Here’s a screenshot of the Windows network diagnostic:

    IMG_1075.jpeg

  • Senior Developer

    @SCavender Ok, so you are actually using the eth0 interface, right?

    In this case you can ignore the warning from the DHCP service if it works as intended.

278
Online

8.2k
Users

15.1k
Topics

141.9k
Posts