• Hey all. I have run into an issue with my FOG server. Some services won’t start on reboot and I cannot start them manually either. I am currently on 1.5.9.68 but was also having the issue on 1.5.9. When I run “systemctl --failed” I get the following:

    root@FOG:~/fogproject/bin# systemctl --failed
    UNIT LOAD ACTIVE SUB DESCRIPTION
    ● FOGImageReplicator.service loaded failed failed FOGImageReplicator
    ● FOGImageSize.service loaded failed failed FOGImageSize
    ● FOGMulticastManager.service loaded failed failed FOGMulticastManager
    ● FOGPingHosts.service loaded failed failed FOGPingHosts
    ● FOGScheduler.service loaded failed failed FOGScheduler
    ● FOGSnapinHash.service loaded failed failed FOGSnapinHash
    ● FOGSnapinReplicator.service loaded failed failed FOGSnapinReplicator

    I ran across this other post that looked identical to my issues. I followed the instructions to update the Systemd scripts but get this result:

    Failed to restart lib-systemd-system-FOGImageReplicator.service.mount: Unit lib-systemd-system-FOGImageReplicator.service.mount not found.
    Failed to restart lib-systemd-system-FOGImageSize.service.mount: Unit lib-systemd-system-FOGImageSize.service.mount not found.
    Failed to restart lib-systemd-system-FOGMulticastManager.service.mount: Unit lib-systemd-system-FOGMulticastManager.service.mount not found.
    Failed to restart lib-systemd-system-FOGPingHosts.service.mount: Unit lib-systemd-system-FOGPingHosts.service.mount not found.
    Failed to restart lib-systemd-system-FOGScheduler.service.mount: Unit lib-systemd-system-FOGScheduler.service.mount not found.
    Failed to restart lib-systemd-system-FOGSnapinHash.service.mount: Unit lib-systemd-system-FOGSnapinHash.service.mount not found.
    Failed to restart lib-systemd-system-FOGSnapinReplicator.service.mount: Unit lib-systemd-system-FOGSnapinReplicator.service.mount not found.

    Any help would be appreciated!


  • Update!

    So I upgraded to Ubuntu 18.04 which did not resolve the issue. I then updated FOG to 1.5.9.71 which must have been release today 🙂 . After completing the FOG update, the services are running and I was able to successfully deploy 2 machines using multicast. I rebooted the server and verified that the services started after a reboot. Thanks for your help and working on this awesome software!


  • @tom-elliott Yes sir, I believe it is complete. During my version changes/installs it all seemed to go normally. We were running 1.5.5 I believe and after purchasing some new computers (Dell Optiplex 5080’s) it was having a driver error when booting. I updated to, I think it was, 1.5.9.62 and it fixed the issue and was able to capture and deploy single machine images. I only noticed the problem when we attempted to multicast. I then went to 1.5.9.68 to 1.5.9 and back to 1.5.9.68 to try and resolve the issue. We can still deploy one machine at a time and have full access to the web interface.

    Edit: I do remember watching the most recent install more closely. When it was at the starting services portion they all said “OK” from what I can remember. Would updating my version of Ubuntu help you think?

  • Senior Developer

    @ravigon Have you completed the installation of FOG? This is the only reason I could think of that the FOG Services would not exist.


  • @sebastian-roth I am running Ubuntu 16.04 LTS

    @Tom-Elliott I’m not super versed in Linux so I was just looking at other threads trying things that may have helped others. The command was “systemctl restart /lib/systemd/system/FOG*.service” which was what you had posted in the thread I linked.

    I just tried “systemctl restart FOGImageReplicator.service FOGImageSize.service FOGMulticastManager.service FOGPingHosts.service FOGScheduler.service FOGSnapinHash.service FOGSnapinReplicator.service”. Services still say “failed” when I check them.

    Thanks for all the replies!

  • Senior Developer

    @ravigon What command is attempting to fun these files?

    First, you should be using:

    systemctl restart FOGImageReplicator.service FOGImageSize.service FOGMulticastManager.service FOGPingHosts.service FOGScheduler.service FOGSnapinHash.service FOGSnapinReplicator.service

    There is no lib-systemd-system-FOG{...}.service.mount anywhere in the system, and neither should there be.

    As @Sebastian-Roth requested, what Version of FOG are you running? If you’re running an older version similar to the “this other post” had, then updating will most likely fix the issue for you.

  • Senior Developer

    @Ravigon Which Linux OS and version so you use?

321
Online

8.2k
Users

15.1k
Topics

141.9k
Posts