check in failed - ignored null byte in input


  • Hi all,

    we use fog on our main site and now we wanted to add another site.
    So I installed the location plugin, set up a storage node and added the dhcp options for the newly created node.

    PXE boot works, but the client isn’t able to check in because of following error:
    08932985-5435-4519-9c32-2366afab6181-grafik.png

    We’re still able to deploy images on our main site.

    Can anyone help us with this?

    Thanks in advance

    Best regards

  • Senior Developer

    @sebastian-roth or the web items are being compressed, but not decompressing for display.

  • Senior Developer

    @Murphy This issue seems very odd. Never seen this before. In the output on screen we see:

    ...
       Version: 3▮3▮y,l
    ...
    Failed
     * SVvp▮▮▮ (In line for 5)
    ...
    

    Both these strings are pulled from the FOG server. Obviously they are somehow corrupted (including non-ASCII characters as well) as George mentioned before.

    I would imagine that some kind of content firewall is actually messing with the communication between FOG server and the client booting up. I am fairly sure this is not caused by FOG itself.


  • @george1421 I tried reinstalling everything from scratch. New Ubuntu Server + fresh install of fog storage node. Unfortunately we get the same error messages again.


  • @george1421 According to the web interface we’re running version 1.5.9 on main and remote site.

  • Moderator

    @murphy what version of FOG at HQ and remote site? In the first error for fog 1.5.9 line 20 is clearscreen() which should not throw that error.

    The second error on line 60 on checking is surely taking some settings from the main fog server to locate it.

    I’m concerned in the screen shot the Version: has gibberish and not a real value there.

343
Online

8.2k
Users

15.1k
Topics

141.9k
Posts