SOLVED manually updated mariadb; installfog.sh fails to see it


  • My MariaDB was on 5.5 on a CentOS 7 fully-updated server and I wanted a newer version, so I removed it:

    Packages Altered:
        Erase mariadb-server-1:5.5.68-1.el7.x86_64 @base
    

    I installed the MariaDB repository from:
    https://downloads.mariadb.com/MariaDB/mariadb_repo_setup

    Packages Altered:
        Obsoleting  MariaDB-client-10.5.9-1.el7.centos.x86_64  @mariadb-main
        Dep-Install MariaDB-common-10.5.9-1.el7.centos.x86_64  @mariadb-main
        Obsoleting  MariaDB-compat-10.5.9-1.el7.centos.x86_64  @mariadb-main
        Install     MariaDB-server-10.5.9-1.el7.centos.x86_64  @mariadb-main
        Dep-Install boost-program-options-1.53.0-28.el7.x86_64 @base
        Dep-Install galera-4-26.4.7-1.el7.centos.x86_64        @mariadb-main
        Obsoleted   mariadb-1:5.5.68-1.el7.x86_64              @base
        Obsoleted   mariadb-libs-1:5.5.68-1.el7.x86_64         @base
        Dep-Install pcre2-10.23-2.el7.x86_64                   @base
        Dep-Install socat-1.7.3.2-2.el7.x86_64                 @base
    

    and verified the database is operational:

    # mysql -uroot -p
    Enter password: 
    Welcome to the MariaDB monitor.  Commands end with ; or \g.
    Your MariaDB connection id is 611444
    Server version: 10.5.9-MariaDB MariaDB Server
    
    Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.
    
    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
    
    MariaDB [(none)]> show databases;
    +--------------------+
    | Database           |
    +--------------------+
    | fog                |
    | information_schema |
    | mysql              |
    | performance_schema |
    +--------------------+
    4 rows in set (0.001 sec)
    
    MariaDB [(none)]> 
    

    I did a new get pull for the latest dev branch of fogproject but the installer does not recognize my MariaDB installation:

     * Checking package: make......................................OK
     * Checking package: mariadb...................................Failed!
                                        
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !! The installer was not able to run all the way to the end as   !!
    !! something has caused it to fail. The following few lines are  !! 
    !! from the error log file which might help us figure out what's !!
    !! wrong. Please add this information when reporting an error.   !!           
    !! As well you might want to take a look at the full error log   !!
    !! in /files/git/fogproject-dev-branch/bin/error_logs/fog_error_1.5.9.65.log !!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
                                                  
    httpd-2.4.6-97.el7.centos.x86_64         
    lftp-4.4.8-12.el7_8.1.x86_64                             
    m4-1.4.16-10.el7.x86_64                  
    make-3.82-24.el7.x86_64                  
    package mariadb is not installed         
    

    Also upgraded the database:

    # mysql_upgrade -uroot -p
    Enter password: 
    This installation of MariaDB is already upgraded to 10.5.9-MariaDB, use --force if you still need to run mysql_upgrade
    

    more details:

    # mysql -V
    mysql  Ver 15.1 Distrib 10.5.9-MariaDB, for Linux (x86_64) using readline 5.1
    
    # rpm -qa | grep -i maria
    MariaDB-client-10.5.9-1.el7.centos.x86_64
    php-williamdes-mariadb-mysql-kbs-1.2.12-1.el7.remi.noarch
    MariaDB-common-10.5.9-1.el7.centos.x86_64
    MariaDB-server-10.5.9-1.el7.centos.x86_64
    MariaDB-compat-10.5.9-1.el7.centos.x86_64
    

    So I guess my question is, how does installfog.sh verify whether or not MariaDB is available?


  • Yes, that solved it. Thanks for the quick work, @Sebastian-Roth!
    How do I mark a topic as Solved? Or is that a moderator-only task?

  • Senior Developer

    @altitudehack Thanks again for reporting this issue. Please pull the the latest dev-branch (1.5.9.67 as of now), re-run the installer and it should be fixed.


  • @Sebastian-Roth as requested:

    [Cent-7:root@fog bin]# grep packages /opt/fog/.fogsettings
    packages='bc curl gcc gcc-c++ genisoimage gzip httpd lftp m4 make mariadb mariadb-server mod_ssl mtools net-tools nfs-utils php php-bcmath php-cli php-common php-fpm php-gd php-ldap php-mbstring php-mysqlnd php-process syslinux tar tftp-server unzip vsftpd wget xinetd xz-devel'
    

    Also:

    [Cent-7:root@fog bin]# yum install mariadb
    ...
    Package 1:mariadb-5.5.68-1.el7.x86_64 is obsoleted by MariaDB-client-10.5.9-1.el7.centos.x86_64 which is already installed
    Nothing to do
    [Cent-7:root@fog bin]# yum install mariadb-server
    ...
    Package 1:mariadb-server-5.5.68-1.el7.x86_64 is obsoleted by MariaDB-server-10.5.9-1.el7.centos.x86_64 which is already installed
    Nothing to do
    

    Thank you!

330
Online

8.2k
Users

15.1k
Topics

141.9k
Posts