effectuer un déploiement avec un firewall activer


  • bonjour à tous, j’ai un très gros problème: je souhaite effectuer un déploiement avec le firewall activé mais seulement que le nfs bloque au niveau de mount et quand je désactive le firewall tout va bien par la suite y’a t’il pas moyen de faire le déploiement avec le firewall activé, mon fog est installer sur ubuntu server 18.04 et j’ai suivi les étapes d’un des commentaire sur le forum mais cela ne m’a pas aidé à grand chose. quelle sont les ports spécifique que je dois activé pour le nfsv3 d’après les info de fog. j’ai installer la dernière version de fog qui est fogproject 1.5.9

    merci pour vos réponses


  • @tom-elliott unicast fonctionne bien mais multicast non cela ne fonctionne pas en multicast j’ai toujours la même erreur comme tout à l’heure


  • @tom-elliott merci beaucoup elliott en faite le problème est que j’étais pas dans le meme réseau pour effectuer le déploiement l’addresse que tu à mentionner est 192.168.1.0/24 hors moi je suis à 192.168.56.0/24. mais dans le firewall j’ai plutot autoriser 192.168.1.0/24 au lieu de 192.168.56.0/24. merci beaucoup pour ton aide. bonne nuit.

  • Senior Developer

    @julio said in effectuer un déploiement avec un firewall activer:

    salut elliott, stp excuse moi de revenir encore te déranger ce soir, voici le problème que j’ai encore recontré après avoir suivi ta procédure comme demandé mon déploiement est callé à ce niveau. que faire stp…

    Multicast is it’s own ball and chain of games. I don’t know exactly but I suspect port 13025 UDP needs to be opened for ufw?

    I am not a huge fan of Multicast (I understand how it can be useful) because it tends to be more trouble than it’s worth. I would suggest starting with unicast.

    The ports that Multicast require are defined in the database though:
    FOG Configuration Page -> FOG Settings -> FOG_UDPCAST_STARTINGPORT

    This is what port starts UDP transfers. So your ufw would likely need something too the effect of:

    sudo ufw allow from 192.168.1.0/25 to any 49502:65536 proto udp
    

    Of course port 49502 Starts the port. So whatever your setting is in the DB (likely the same as what I have stated)


  • @tom-elliott salut elliott, stp excuse moi de revenir encore te déranger ce soir, voici le problème que j’ai encore recontré après avoir suivi ta procédure comme demandé mon déploiement est callé à ce niveau. que faire stp…erreur.PNG


  • @tom-elliott thank you very much tom-elliott. ça marche très bien.

    pour ceux qui ont eu le même problème que que moi suivez ces étapes de tom elliott cela fonctionne bien. chez moi ça marche. merci une fois de plus.

  • Senior Developer

    @julio
    You can specify a port that NFS would run off of by editing the file /etc/default/nfs-kernel-server

    Look for RPCMOUNTDOPTS=--manage-gids and replace it to look something like: RPCMOUNTDOPTS=-p 13025. Then restart nfs-kernel-server systemctl restart nfs-kernel-server

    While I’m unfamiliar with ufw (I know what is, just no clue what your network looks like) you can run (Please change the 192.168.1.0/24 as appropriate for your network environment):

    sudo ufw allow from 192.168.1.0/24 to any port 111
    sudo ufw allow from 192.168.1.0/24 to any port 2049
    sudo ufw allow from 192.168.1.0/24 to any port 13025
    

    For those wondering how to specify port in Redhat based edit, or create if not present, the file /etc/sysconfig/nfs Add or edit the MOUNTD_PORT=13025. This will configure NFS for both UDP/TCP. (Restart NFS services as needed - systemctl restart nfs-server

    Configure firewall (assuming RHEL based 8.0 or higher (CentOS Stream, etc…)

    sudo firewall-cmd --add-port=111/tcp --permanent
    sudo firewall-cmd --add-port=111/udp --permanent
    sudo firewall-cmd --add-port=2049/tcp --permanent
    sudo firewall-cmd --add-port=13025/tcp --permanent
    sudo firewall-cmd --add-port=13025/udp --permanent
    sudo firewall-cmd --reload
    

    I will also note I’m just using 13025 as a random port in the higher range to ensure less potential of affecting an existing/in-use port on your machine. Feel free to change this to whatever port you feel you would like to use.


  • @george1421 said in effectuer un déploiement avec un firewall activer:

    @julio FOG has this topic on enabling the firewall and using FOG: https://forums.fogproject.org/topic/6162/firewall-configuration

    As you posted NFSv3 is the problem. It needs many ports open to function correctly. We are looking at NFSv4 as a possible solution since NFSv4 can use only a single port.

    Running this command on your ubuntu fog server may enable the right ports needed ufw and nfs-kernel-server

    salut george stp regarde un peu mon truc comment je peux utilisé cette commande que tu m’a envoyéCapture11.PNG

  • Moderator

    @julio FOG has this topic on enabling the firewall and using FOG: https://forums.fogproject.org/topic/6162/firewall-configuration

    As you posted NFSv3 is the problem. It needs many ports open to function correctly. We are looking at NFSv4 as a possible solution since NFSv4 can use only a single port.

    Running this command on your ubuntu fog server may enable the right ports needed ufw and nfs-kernel-server

324
Online

8.2k
Users

15.1k
Topics

141.9k
Posts