• Hello folks,

    I think I have multiple issues going on here, but we’ll tackle one at a time.

    So I was trying to capture a new image yesterday, and everything looked like it was going well. I was going to leave it be and finish on its own, but it threw an error as soon as I was walking away and I can’t decipher what it’s trying to say.

    Any help would be appreciated!

    This is the error is threw when the capture/upload task failed
    IMG_3761.jpg

    This is when it rebooted.
    IMG_3762.jpg
    IMG_3763.jpg


  • @sebastian-roth
    Thank you for the guidance. I dismounted the iSCSI share, but I couldn’t run a fsck on it, as it said the “Super block was not readable.” So I decided to just reboot.
    I made sure all the NFS services came back on startup, because those occassionally don’t start or crash.

    Ran mount, noticed that the /images share mounted differently than before. \dev\SDI intead of \dev\SDJ Screen shot below. However, it is now RW not RO. Just tested as well with capturing an image and it worked.

    Thanks!

  • Senior Developer

    @racera4 See what it tells us in the mount output:

    ... /images type ext4 (ro, ...)
    

    With ro meaning read only! I have no idea how this happened. Possibly a network hickup with the iSCSI and ext4 switched to read only just to be safe. I would suggest unmounting it, then do a full filesystem check to make sure there is nothing wrong with it and then possibly a reboot of the whole system.


  • @sebastian-roth Here is the results of running mount on the FOG server. Just so you have a bit of background. I have a Drobo with 16TB of storage mounted through iSCSI as my /images folder
    mount.png

  • Senior Developer

    @racera4 Don’t think I have seen this error before. From the pictures you posted the message pigz: abort: write error on <stdout> (Read-only file system) is most suspicious! We see that it started to write data to the disk on your FOG server but at some point it hit the wall. As you do see the new error Setting permission on ... after a reboot I would imagine that the filesystem on the server was actually set to read only for some reason. Usually only happens when there is a major error.

    Please run mount on your FOG server and post output here.

346
Online

8.1k
Users

15.0k
Topics

141.3k
Posts