Win 10 Pro Product key not installed probably


  • Hello all,

    we have a fog server installed in are network for a couple of months now and we are booting all desktops from pxi. all desktops are using windows 7 on this moment but we would like to chanch to windows 10. all desktops have a windows key sticker on it. and we have add almost every key in the host product key field in fog GUI. we have over 100 desktops that need to be upgrade to windows 10 with a key installed and activated. it is to much work to add a key to every desktop that needs upgrading. so we would like to automate that with fog.

    The last few weeks i have tried solving the issue with windows 10 pro not being activate after deployment. i have tried several things such as making a new windows 10 image and capture it with out a installed windows key, also have tried windows key plugin. but nothing works. i have tried every possible setting that i can find to change something.

    Settings that i have apply: Host-> Active Directory -> Name Change/AD Join Forced reboot? Is enabled.
    Forced reboot is globe enabled.

    Windows key plugin is also enabled, but if host product key field works then we don’t need that.

    This is what we get from a deployment machine:
    (hostnameChanger is after deployment changing the hostname that is working, but no key is installed)

    --------------------------------HostnameChanger-------------------------------
    18/03/2021 10:41:30 Client-Info Client Version: 0.12.0
    18/03/2021 10:41:30 Client-Info Client OS: Windows
    18/03/2021 10:41:30 Client-Info Server Version: 1.5.9
    18/03/2021 10:41:30 Middleware::Response Success
    18/03/2021 10:41:30 HostnameChanger Checking Product Key Activation
    18/03/2021 10:41:31 WinActivation Installing Product key
    18/03/2021 10:41:41 HostnameChanger Checking Hostname
    18/03/2021 10:41:41 HostnameChanger Hostname is correct

    But if i check windows settings still no windows key is installed or activated. also slmgr.vbs /ato does nothing because no key is installed…

    what can i try next?


  • @sebastian-roth Sorry for my late response, i use windows 10 build 20H2.
    I have tried installing the key with slmgr.vbs manually, that’s not working so i think its a bug in windows…

    i have tried finding a old windows 10 build (2004) to try if it works there, but no luck so far…

  • Senior Developer

    @martijn159 Are you able to set the product key and activate using slmgr.vbs manually? In the fog-client code we simply use those slmgr.vbs calls too.

    So if it does work manually I would think it does work with the fog-client as well - it did work in the past as far as I know.

    We just had another post where a user reported that setting a key and activating it wouldn’t even work manually in Windows 10 20H2.

    Which (build) version of Windows 10 do you use?

266
Online

8.1k
Users

15.0k
Topics

141.4k
Posts