• Hello, today I have installed Fog Project, but I could not boot users in virtual environment via fog server. The related error is as follows.

    I use windows DHCP server and 66: ip address of my fog server 67: ipxe.efi, I do not know what I did wrong, users do not boot on the server

    I would appreciate if you could tell the way I’m writing ridicule from turkey 🙂

    fog server.png

    Thank You

  • Moderator

    @kamil .fogsettings file is hidden. In linux when a file name begins with dot ( . ) then file is hidden.

    Question on bitlocker. Yes and no will this be a problem. No it will not be a problem in that FOG will backup the protected images in RAW disk mode.

    Yes it will be a problem because fog will not be able to resize the disk because the partitions are protected with bitlocker. Also if you move the image to a different computer, that bitlocker protected disk will not boot because the values stored in the TPM chip will be different on a different computer.

    So while you can copy a bitlocker protected disk you can not move the image to a second computer and think that it will work.


  • @kamil
    the corresponding virtual machines are running on my computer and my computer’s disks are encrypted with bitlcker, can this have an effect?


  • @george1421 said in fog server user boot problem:

    fogsettings

    How can it say that the fogsetting file does not exist?
    y4sLmFUL0o.png
    Fhf0bU0yJE.png

  • Moderator

    @kamil When you fixed the IP address following the link I give you. Did you update the /opt/fog/.fogsettings file with the correct IP address then rerun the fog installer? There is still something wrong if you cannot edit the image definitions after you make a new one.


  • @george1421

    Hello, I actually tried to say that I did what you said, the language was a different problem, I think I am creating a new image as you said, but I cannot edit it

  • Moderator

    @kamil said in fog server user boot problem:

    I just tried saying HELLO, but the problem is not solved, I cannot add in the same way.

    Please explain the problem clearly in your native language. I don’t understand add “I cannot add in the same way”. I think you are saying one thing and I’m thinking something else.

    To add a new image press the create new image button
    create image.png

    When you create the new image then I want to make sure you can edit the image definition you just created.


  • @george1421

    I just tried saying HELLO, but the problem is not solved, I cannot add in the same way.
    FDH4DCcHN4.png

  • Moderator

    @kamil Ok lets make a new image definition then. Created it, then see if you can edit it after making it. If you can then go to the host definition and see if you can select it. If everything is OK go back to the image definitions and remove the broken definitions.


  • @george1421

    Hello, I cannot edit when I enter the image, it is redirected to an empty page.
    yapılıyorRi6vEsm4pG.png KBUrtXRlbh.png

  • Moderator

    @kamil This is very strange you have image definitions but when you go into host definitions they do no show up in the selection. This should not happen unless all image definitions are marked disabled (checkbox in image definition). Would you post a screen shot of one of these image definitions?

    image_enabled.png


  • @george1421

    hello situation this is how i can’t assign these images to the computer
    tn8H2XCYW1.png

  • Moderator

    @kamil OK that is fine, if you fixed one part and now have a second issue.

    If you can get into the fog iPXE menu then we can think about your second problem.

    Will you post a screen shot from the fog web ui, Images->List all Images. Page. Do you have any images created first? The workflow is to create image definitions then assign hosts to the image definition.


  • @george1421 said in fog server user boot problem:

    p a s

    hello yes the problem has changed with your referrals

    Current problem, I cannot assign the generated image to computers.

    fog vesion
    Latest Version: 1.5.9

    DHC 66 and 67

    7qgFlycFa1.png

    k059tlQMqG.png

  • Moderator

    @kamil The error from your initial picture does not match your “problem”. If you can’t get into the iPXE menu then the rest doesn’t matter. Or has the problem now changed from your original post?

    to save a little time, lets collect some background information.

    1. FOG version
    2. output of the following commands executed on the FOG server
      ip a s
      netstat -an | grep :69
    3. A screen shot of your dhcp server’s settings for dhcp option 66 and 67. Mask anything that is not relevent to dhcp option s 66 and 67

  • @george1421

    I did as you said hi, I did not install from scratch and did not provide ip change. My problem is that I am creating an image, but I cannot assign it to the relevant computer.Thanks.
    ![alt text](fogserver2.png image url)
    k4mIZgt71E.png

  • Moderator

    @kamil Ok that explains why you are having troubles. There is a fog docs page that covers changing the fog server IP address after FOG is installed: https://docs.fogproject.org/en/latest/reference/change_fog_server_ip_address.html

    Also is your fog server now at 10.1.1.91? Is that accurate? If it isn’t you need to update the dhcp server settings for FOG.


  • @george1421

    As you said hello, since it is a virtual environment, the first installation ip address is assigned by oracle to go to the internet and install it, then I make the ip change with windows dhcp.

    I do not use DHCP service in fog server DHCP is installed in Windows environment

    What kind of path should I follow?

  • Moderator

    @kamil There are two things that give me doubt.

    1. The target pxe booting computer has ip address of 10.1.1.90 and fog server has 10.1.1.91. I find this suspicious. I would think the FOG server has a dhcp address. The fog server will not work if its IP address is changed after FOG is installed. The fog server must have a static assigned IP address before the fog programs are installed. Will you confirm the actual IP address of the fog serer is 10.1.1.91?
    2. Is the screen shot a picture of a virtual machine booting? The boot sequence doesn’t look correct. It looks like your virtual host server might be virtualbox??

330
Online

8.1k
Users

15.0k
Topics

141.3k
Posts