Switching to Gpxelinux



  • i can confirm that before i reached a speed at constant of 100 to 150 mbps, now with changing to ipxe i reach peaks on 600 mbps.
    so kevin is right that when transfering big files its a huge change.
    the change i see is that before the grapic on the homepage was constant 100 till 150 and now its more spikes but with incredible speed difference.
    i think when its deploying an image in which there are as kevin states big files it reaches very high speeds compared to the standard tftp protocol.
    by this confirmed :-)



  • Imaging itself stays the same speed. However, if you have an ISO, say UltimatebootCD which is over 500 MB, using Gpxelinux will load this significantly faster than over TFTP. Literally, it’ll go from minutes to seconds.



  • Are we talking faster imaging times here?



  • glad to hear you got it working for you



  • small update from me.
    i did not get it to work on GPXE butt !!!
    I got it to work with Ipxe :-) on http :-)



  • maybe som other info
    i’m running Ubuntu server 10.04 LTS and fog 0.32
    also when i try to load the gpxelinux.0 trough my isc dhcp3 server is fails -> it just runs block , only pxelinux.0 works
    all files are from syslinux 5.10 including the vesamenu.c32

    thnx for allready looking into this case.



  • i did run the command and tested in my browser, got a download request and i could browse the folder contents in IE
    i just tried to adjust the dhcp server with option 209 and 210 --> still no luck ?
    can you help me please ?



  • wolf,

    Did you run this command, [B][FONT=sans-serif][COLOR=#000000]ln -s /tftpboot/fog fogboot [/COLOR][/FONT][/B][FONT=sans-serif][COLOR=#000000]from the [B]www/var folder[/B][/COLOR][/FONT]? If you ran through the guide, steps 1-8, it will still boot through tftp until you run that command.



  • Hi,

    My name is christophe and i’m kinda new to all this fog happening.
    I tried to follow your guide but can’t get any of it to work.
    i have a running configuration in VM on the latest virtualbox.
    i installed syslinux 5.10 ( latest version ) and followed your wiki page.
    but when i make the changes to gpxe it does not work, the dhcp server keeps booting to tftp, adjusting the links in the bootmenu config file as suggested it simply replies that the file does not excist or its a wrong path.
    i tried to acces the files in my internet explorer and it works just fine.
    can some help me get my fogserver up and running on http protocol please ? or indicate what i can be doing wrong ?
    it seems that when de dhcp starts it denies the http protocol but on the website of syslinux they say it should support http protocol now.

    help !!!

    thnx


  • Developer

    A word of warning, we tried gpxelinux and http in our live environment, but found that performance was much worse that pxelinux and tftp.
    Looking at the wireshark traces showed lost of retransmissions, whci is well documented on the web, mainly in a vmware environment. From what I could see on the web there is no solution, so we have reverted back to pxelinux and tftp.



  • I think all you would need to do is point option 66 or 67 in DCHP settings from pxelinux.0 to gpxelinux.0. I have not personally tried this, but that should be all that’s needed.



  • switching to the faster gpxelinux sounds great.
    I’m gone through the wiki article but stuck on step 7 (dhcp).
    We don’t use fog as dhcp server, this will be handeld by our ms 2008 server.

    Can i skip this step and it should still work?
    Or do i need to configure something on the win server ?


  • Developer

    I’ve not tried it, but the boot file that gets generated has the http path rather than the file path.
    It must use

    FOG_TFTP_PXE_KERNEL
    FOG_PXE_BOOT_IMAGE

    for its kernel and init.gz.

    We use capone ( with a couple of tweaks ) tied to the system serial rather than multicast.
    The tweaks we have mean that we get an image history for each PC, so we know if it has a history of rebuild.


  • Moderator

    does multicast work, anyone know?


  • Moderator

    Thanks Kevin



  • gpxelinux uses http as the protocol instead of tftp. The big advantage is that items from the pxe menu will load significantly faster than tftp, which is limited to around 2-4 MB/s. In a test environment, and loaded an ISO that took 4:52 to boot using tftp and pxelinux. When using http from gpxelinux, the same iso was able to load in 14.9 seconds.


  • Moderator

    Nice share, will have to test this out.
    What is the advantage of using gpxe?





  • I have it working with HTTP, I just ran it through tftp that time so it would stay on the screen long enough for me to take the screenshot. Everything is working as it should minus that window above :)


  • Developer

    I just missed one step I think.
    When you create a task, it puts in the default values for kernel and boot image, you need to go into fog settings and set the following
    FOG_TFTP_PXE_KERNEL
    FOG_PXE_BOOT_IMAGE
    to
    [url]http://192.168.1.104/fogboot/kernel/bzImage[/url]
    and
    [url]http://192.168.1.104/fogboot/images/init.gz[/url]

    substituting your own Ip address

    If you don’t change these then it will use tftp.

    BTW my screen looks normal, I’m using virtual box


 

345
Online

41.4k
Users

11.8k
Topics

112.2k
Posts