• Hi there

    I am having problems with Multicast. It’s been working an absolute dream, doing 12 machines at a time and it usually takes a few mins. Then all of a sudden the rate has decreased dramatically. Now it’s looking at over 1 hour to do 12 machines from the same image which is 15gb in size. The rate drops to around 180mb/min. If I do a single image in Unicast it’s going at 8gb/min which is what the rate for Multicast was previously.

    If I deploy the image to each machine individually using unicast, it’s still quicker than the Multicast deployment.

    I am not sure where to troubleshoot this, but it’s been working fine this morning and then all of a sudden started to go real slow.

    Any ideas?

  • Well rebooting the switch does seem to have had some effect, this batch are now multicasting at 2Gb/min. I’ll look at getting it replaced, it’s a noisy beast anyways.

  • @sebastian-roth Morning.

    Thanks for the reply. Not with the very same clients, same model of machine but different clients.

    I tried again several times with a few, now the speed just sits at 200-250mb/min. Nothing has changed, when this happened yesterday it was after I’d already imaged perhaps 48 clients via Multicast, then the next batch was going much slower.

    I’ve rebooted the FOG server, the switch is a unmanaged Netgear 48 Gbps, but I’ll give that a reboot also.

    As said, when I do them via unicast, the speeds are fine. It’s very odd.

  • Moderator

    @Goll420 Multicast can be tricky! It’s interesting you say that it used to be full speed - was that with the very same 12 hosts? Are all your hosts and the FOG server in the same subnet? New network equipment?

    With multicast every hosts needs to be “in line” with the others. So one simple bootleneck anywhere will slow down the whole lot. So for example, one host is down to 100 MBit connection or having an issue with the disk.

    I would try to tackle this issue using a method called “divide an conquer”. Split the group of 12 in two and let both of them do a multicast session one after the other. I would expect one group to go fast and the other one to go slow. If that is the case, split the slow group in half again and do a multicast for those 3 and 3 subgroups one after the other. See if you can nail it down that way.

    If both groups (of 6) are going slow than I would start looking at the switch they are connected to.

  • Also worth noting I’ve ran through the troubleshooting steps on the wiki and it’s communicating fine. There is nothing on there about bandwidth dropping rate.

  • The previous image shows the rate of bandwidth being transferred via Multicast at 240.81Mb/Min

    This image shows one of the 12 clients i have deploying via unicast at the same time.

    I really don’t understand why this has happened this morning???

  • IMG_20210126_142933.jpg

  • Also rebooted the FOG server and tried again, 200mb/min.

    Stopped the job and began deploying unicast.

    Full speed again. I have got no idea why this has suddenly started happening, it was fine this morning.