No configuration method succeeded


  • Hi

    I didn’t find soluce on different post, so I make a new post.
    I configure my DHCP server (windows 2012 r2) to enable UEFI boot, but I have this error
    (IMG_20210125_115158.jpg

    I disabled RSP on my switch, I set ipxe.efi (undipxe doesn’t match)
    What else ?

    thanks

  • Moderator

    @phm2000 I don’t know that model but I did find that your switch does support “green ethernet” mode. I’m not saying that this IS the problem but if your only solution is to disable STP then I would look to see if green ethernet is enalbed on your switch. According to this article its disabled by default: https://community.hpe.com/t5/Comware-Based/How-to-disable-IEEE-802-3az-Energy-Efficient-Ethernet-feature-on/td-p/6896946# Look at the accepted solution.

    Disabling STP on user facing ports is not the best choice. You may need to get with a switch engineer to understand why turning on RSTP does not solve your problem (because turning off STP solves the net booting). From your description it sounds like the port is in standard STP mode even if you set it to RSTP. I assume (with RSTP on) placing a dumb (unmanged) cheap switch between the building switch and the pxe booting computer will also mask the problem. We will typically recommend this for people to test to see if the problem is spanning tree or not without changing the switch settings.


  • What manufacturer and model are your network switches?

    It’s a HPE 5130

  • Moderator

    @phm2000 said in No configuration method succeeded:

    the only mode that allow pxe is to disable spanning tree.

    This is unique since this is the first time I heard that RSTP behaves this way. RSTP and MSTP should start forwarding packets right away before listening for a BPDU packet. Where traditional STP listens first for 27 seconds then starts forwarding data.

    What manufacturer and model are your network switches?

    I have also seen where green ethernet (802.3az) configured on the switch could cause this too. This is where the port doesn’t wake up fast enough from low power state.


  • @george1421 said in No configuration method succeeded:

    @phm2000 said in No configuration method succeeded:

    I disabled RSP on my switch,

    I would think this is the opposite of what you want. It seems like it could be a standard spanning tree issue, where RSTP would address the issue. I’m thinking this because ipxe is seeing the network adapter.

    Thanks, but the only mode that allow pxe is to disable spanning tree. I tried STP, RSTP, PVST and MSTP but pxe doesn’t launch.

  • Moderator

    @phm2000 said in No configuration method succeeded:

    I disabled RSP on my switch,

    I would think this is the opposite of what you want. It seems like it could be a standard spanning tree issue, where RSTP would address the issue. I’m thinking this because ipxe is seeing the network adapter.

293
Online

8.7k
Users

15.4k
Topics

144.1k
Posts