• Hello,

    I set the “fog.advancedlogin” to “All hosts”

    I set an own menu item to “Advanced Options”

    When I boot in the menu, I see the Advanced Menu item … he asking for a login.
    After login, he switch back to the main menu, which looks exactly same as before.

    Where is my mistake? I want display a menu item only after login.

    Thank you!

  • Senior Developer

    @seppim said in Advanced Login:

    I guess I need to set the “Advanced menu command”? But why is this not out of the box working?

    Yes, you need to add some custom advanced menu that you want to see after the login. There is no default.

    Here is some example code you can start working on:

    menu
    item --gap -------------- iPXE advanced boot menu --------------
    item DBAN Boot and Nuke
    item SHELL iPXE Shell
    item RETURN Return to previous menu
    choose --default RETURN --timeout 10000 target && goto ${target}
    
    :DBAN
    kernel ${boot_url}/dban/dban.bzi nuke="dwipe" silent vga=785
    boot
    goto MENU
    
    :SHELL
    shell ||
    goto MENU
    
    :RETURN
    chain http://${fog-ip}/${fog-webroot}/service/ipxe/boot.php?mac=${net0/mac} ||
    prompt
    goto MENU
    
    autoboot
    

    Here is more stuff if you need: https://forums.fogproject.org/topic/7329/sub-menu-within-fog-advanced-menu


  • @sebastian-roth Hello Sebastian,

    for my unterstanding:
    When I choose “Advanced menu” in PXE menu, I log in and get back to the menu and see the menu items which has “Advanced Login Required”.

    1. I enable Advanced Menu Login in iPXE General Configuration -> Advanced Menu settings:
      8f45bb27-c87c-4530-89a4-810e3d51b4ef-grafik.png
      now the menu item is displayed:
      2633148a-b3f4-420d-be6a-574bdcd52d27-grafik.png

    2. I login and hit enter, then this happen:
      8866bf04-1fdb-44b3-a4bc-912ae95ec181-grafik.png

    I guess I need to set the “Advanced menu command”? But why is this not out of the box working?

    Or did I misunderstood this feature?

  • Senior Developer

    @seppim said in Advanced Login:

    I want display a menu item only after login.

    If that is what you want to do you need to take a look at iPXE General Configuration -> Advanced Menu settings. Here you can define a custom iPXE script that is being called after the login.

    If you don’t have a text field for Advanced menu command then you need to disable your Adblock browser addon.

    I set the “fog.advancedlogin” to “All hosts”

    I think you need to switch that back to “Advanced Login Required”.


  • [push]

    Maybe someone has in idea whats wrong?

285
Online

8.2k
Users

15.0k
Topics

141.5k
Posts