[SOLVED] Using Preseed in PXE for autoinstallation HTTPS error


  • Hi,

    We re trying to autoinstall Ubuntu 20.04 with FOG.

    Our iPXE parameters are :

    kernel tftp://${fog-ip}/os/ubuntu/20.04.01.LTS/linux
    initrd tftp://${fog-ip}/os/ubuntu/20.04.01.LTS/initrd.gz
    imgargs linux auto=true root=/dev/nfs boot=casper netboot=nfs nfsroot=${fog-ip}:/images/os/ubuntu/20.04.01.LTS/ locale=fr_FR.UTF-8 keyboard-configuration/layoutcode=fr debian-installer/allow_unauthenticated_ssl=true url=http://${fog-ip}/preseed/preseed.cfg splash ip=dhcp rw
    boot || goto MENU

    The system is booting, but when trying to get the preseed file in the debian-installer, we have an error about FOG CA-CERT as we have installed FOG with the HTTPS option.
    In the debian-installer i open a console and execute :
    wget http:(or https)//ip_of_my_FOG_server/preseed/preseed.cfg , i also have the error of certificate.

    If using :
    wget --no-check-certificate http:(or https)//ip_of_my_FOG_server/preseed/preseed.cfg
    It is downloading the file.

    I thought the option debian-installer/allow_unauthenticated_ssl=true in the imgargs options should correct this, but it is not.

    Any idea ?


  • @sebastian-roth Hey thanks a lot, it worked!

  • Senior Developer

    @Jacques-Olivier Just found this: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=913740

    It talks about an issue where it would not properly use the option debian-installer/allow_unauthenticated_ssl=true when the request is being redirected from HTTP to HTTPS.

    So try changing your iPXE parameters to “… debian-installer/allow_unauthenticated_ssl=true url=https://${fog-ip}/preseed/preseed.cfg splash ip=dhcp rw” and see if that works.

294
Online

8.5k
Users

15.3k
Topics

143.3k
Posts