Not able to login to server after firewalld configuration


  • Hello Everyone. I have an issue that hopefully you guys can help me with. I am not able to multicast and found an article that I tried to do to see if it would fix the issue. I entered the following commands via SSH to my fog server. I am able to log in to the web interface, but not the server after doing this. I tried SSH as well as at the server itself. I did not change the password and it worked fine prior to doing this.

    I am running FOG 1.5.9-RC2 on CentOS 8

    yum install firewalld -y
    systemctl start firewalld
    systemctl enable firewalld
    for service in http https tftp ftp mysql nfs mountd rpc-bind proxy-dhcp; do firewall-cmd --permanent --zone=public --add-service=$service;
    done

    echo “Open UDP port 49152 through 65532, the possible used ports for fog multicast”
    firewall-cmd --permanent --add-port=49152-65532/udp
    echo “Allow IGMP traffic for multicast”
    firewall-cmd --permanent --direct --add-rule ipv4 filter INPUT 0 -p igmp -j ACCEPT
    systemctl restart firewalld.service
    echo “Done.”

    I haven’t tried yet to see if multicast works after doing this. I tried doing a multicast test by using the following command on the server: udp-sender --file /opt/fog/.fogsettings --log /opt/fog/log/multicast.log --ttl 1 --nopointopoint --portbase 9000

    I used udp-receiver on a secondary unix machine and it didn’t prompt or send file.

    Thanks in advance for any help.


  • @george1421 Thanks for the help. I was also trying to use the username of “fog” instead of root at the server. That’s what I get for not knowing much about linux…lol

  • Moderator

    @maxwellmw In your for service loop I don’t see ssh in the list.

    in the console window of your fog server key in
    firewall-cmd --permanent --zone=public --add-service=ssh

349
Online

8.2k
Users

15.0k
Topics

141.5k
Posts