Problem with new FOG 1.5.9 installation


  • If you install fog 1.5.9, this is the problem:

    Update fogstorage database password.........................Failed!
    
    Starting The PHP 7.3 FastCGI Process Manager...
    Nov 15 06:00:03 backup systemd[1]: Started The PHP 7.3 FastCGI Process Manager.
    ERROR 1146 (42S02) at line 1: Table 'fog.globalSettings' doesn't exist
    

    in mysql logs

    2020-11-15  6:55:07 40 [Warning] Access denied for user 'fogmaster'@'localhost' (using password: YES)
    2020-11-15  6:55:07 41 [Warning] Access denied for user 'fogstorage'@'localhost' (using password: NO)
    
    

    The problem occurs on Ubuntu 16.04 -20.04, as well as on Debian 10.06.
    Can you please tell me what you can do?

  • Senior Developer

    @belac said in Problem with new FOG 1.5.9 installation:

    manually update
    on all your storage nodes

    This is not for your FOG master node. Hope you have a copy of the old fogsettings file or we might be able to get the last fogmaster DB credentials from a backup of the config.class.php file in /home/fog_web_1.5.9.BACKUP/…


  • i am having a possibly similar issue after upgrading to 1.5.9.
    During the install it prompted me that it was changing the fogstorage password. i copied the note which was:
    The current fogstorage database password does not meet high
    security standards. We will generate a new password and update
    all the settings on this FOG server for you. Please take note
    of the following credentials that you need to manually update
    on all your storage nodes’ /opt/fog/.fogsettings configuration
    files and re-run (!) the FOG installer:
    snmysqluser=‘fogstorage’
    snmysqlpass=‘redacted’

    i changed the referenced settings, changing the user to fogstorage from fogmaster. then reran the install as noted. then ran the database update from fog web ui and got error:
    Failed to query: Error: SQLSTATE[42000]: Syntax error or access violation: 1142 ALTER command denied to user ‘fogstorage’@‘localhost’ for table ‘nfsGroupMembers’ Error Message: Error Code: “42000”, Error Message: [“42000”,1142,“ALTER command denied to user ‘fogstorage’@‘localhost’ for table ‘nfsGroupMembers’”], Debug: SQL: [92] ALTER TABLE nfsGroupMembers ADD COLUMN ngmHelloInterval VARCHAR(8) AFTER `ngmMaxBitrate

    in cli (after hitting enter):
    Update fogstorage database password…Failed!

  • Senior Developer

    @filisdiez At one point the installer waits for your action. You are asked to open the FOG web UI to update the schema (create the database layout and populate it). As far as I see this error occurs if you don’t do the schema update but proceed with the installer.

366
Online

8.6k
Users

15.3k
Topics

143.5k
Posts