• Hi everyone,
    I’ve got FOG running on Ubuntu 11.10. I am attempting to use Scheduled Tasks to wake a group of lab computers up. I started out by attempting to schedule a Cron style task for the group. That didn’t work. The computers just didn’t turn on. I then went in and manually deleted (by truncating scheduled tasks in the database (instructions found on here)) the task.
    After the cron style task didn’t work, I just assumed I messed up, so I tried scheduling single task for a single computer. That also didn’t work. I was able to view it in the Schedule Tasks page on the web interface. Once the time for the task to execute comes, the scheduled task vanishes and nothing happens.
    So, I then thought the WOL just wasn’t working, so I tried to manually wake the computer up through fog. That worked fine.
    Then I tried to schedule a single execution imaging task to the same computer. That doesn’t work.
    If, however, I wanted to image that computer without scheduling it, I would be able to start the task and FOG would successfully wake the computer and start the imaging task.
    Anyone have any ideas?

  • This post is deleted!
  • Moderator

    I didn’t die. After making the changes to the php function calls, did this solve your problems with task creation through the webUI?

  • [url]http://fogproject.org/forum/threads/cannot-create-tasks-task-manager-blank.3823/#post-9458[/url]

    works fine now on 12.10 - expecting it’s the result of a new php base in the repos…

  • I use fog on both 11.10 and 12.04 without issue, but it’s essentially a vanilla install in both of those cases… I just tried adding fog to a 12.10 box I had already built and made a series of modifications on, and I too am now not able to perform any operations as nothing shows in the tasks. I have also seen nothing in crontab for the fog user and I have also noticed that a quick registration or a full registration never complete either: like there is some sort of weird permissions issue specifically with this version of ubuntu…

    any ideas?

  • Did Chad-bisd die or what? Is there an answer to this problem? I have tried Ubuntu 12.04, 11.04, 10.04 and all have the same failure as described above. Come on, all you people that claim your using fog, give us the info if it really works!

  • Another effect: I dont see anything under sheduled tasks (even the menu disappears)

  • Hello,
    I have the same issue and I recognized that in the /tftpboot/pxelinux.cfg no special file for the host is created.
    If I set a normal deploy, this fIle is created. So the issue is in the step which creates this files, but I have no idea which scripts are invoved there

  • I have done the following:
    Checked bios time & system time. Both are the same (and correct)
    I have scheduled a cron style task in FOG and am unable to find it in crontab. Have looked using the following commands (This is my very first attempt at anything cron, so if I am incorrect, please point me in the right direction)
    ls /var/spool/cron
    crontab -l -u fog
    No jobs appear to be scheduled.
    Manually scheduled a cron job with the following commands
    crontab -e -u fog
    created a job to rename a text file on my desktop. This executed successfully on time and the text file was renamed.

    In the fog database I can look at the scheduledTasks table and see my scheduled tasks there.

    Unfortunately, I don’t know enough about how FOG works with Ubuntu to create these tasks to understand WHY FOG is unable to successfully create the Cron job.

  • Moderator

    Check the date/time of your FOG server in BIOS and in Ubuntu. Since cron is time sensitive, make sure that is correct first.

    Schedule a cron style task, then check the crontab for the fog user and see what you have. Also, have you tried scheduling a non-FOG task/script to run as fog user and see if that works? Make sure the cron jobs are getting created, and make sure your cron deamon is actually executing tasks.