• I just got in some Dell Precision 3440 towers.
    In trying to net boot into FOG. Boot screen displays "start pxe over IPv4 on mac (number). then a 3 line error message that goes away too quickly to read, then the Dell Support Assist page reporting no bootable devices found.

    I just recently imaged 40 Precision 3431’s and had no trouble at all. Both are set to UEFI mode, but on the 3431’s I was able to set the onboard nic as Legacy boot device. These latest machines don’t seem to have that option (that I can find). Any ideas?

    I’m running Fog 1.5.5

    Thanks so much!!


  • This post is deleted!

  • My bad!! Disregard the last. I had changed to ipxe.efi in scope section only … not sever options. Fixed that and it’s booting to Fog now.

    Thanks so much!!

  • Moderator

    @rmullis said in Can't net boot into Fog:

    "start pxe over IPv4 on

    Per your suggestion I tried ipxe.efi but am still getting the same result.

    The top comment makes me think the computers are in uefi mode. Its strange the bottom comment you get the same results.

    I want you to go into the bios (firmware) on those target computer and

    1. Confirm these computers are in uefi mode
    2. Confirm that secure/safe boot is disabled.
    3. Confirm that the disk mode is in ahci mode not Raid-on mode (fix it now or it will be trouble at the next step).

    I’m betting secure boot is enabled stopping the load of ipxe.efi.

  • Senior Developer

    @rmullis said in Can't net boot into Fog:

    downloding NBP file

    That really sounds like an UEFI based device. While undionly.kpxe definitely won’t work for this but ipxe.efi should. Have you made sure the settings are applied? The things you describe sound a lot like it’s not loading ipxe.efi.

    dhcp is running on a poweredge 2650 with windows server 08

    Are you serious? Windows Server 2008!? In this case you can’t properly setup PXE booting configuration for both legacy BIOS and UEFI machines as described in the wiki. You might think about disabling the PXE information in your Windows DHCP server and use dnsmasq as DHCP proxy (at least dnsmasq version 2.76 needed!)


  • Thanks for the help.

    dhcp is running on a poweredge 2650 with windows server 08

    Originally option 67 was set to undionly.kpxe. Per your suggestion I tried ipxe.efi but am still getting the same result.

    I video’ed the boot and slowed it down enough to read what I THOUGHT was an error message, but was just info that it was “downloding NBP file”

  • Moderator

    So what precisely do you have configured for dhcp option 67 on your dhcp server?

    What is your dhcp server mfg and model?

  • Senior Developer

    @rmullis Sounds like the new devices are UEFI only and need ipxe.efi to boot from it. What is providing DHCP in your network?

    By the way, do you have an image created in UEFI mode yet?

420
Online

7.8k
Users

14.8k
Topics

139.5k
Posts