• Hi there,
    we have in school a room, there were acer computers and they were registerd in Fog with Room402_01 Room 402_02 etc.
    now i have new Computer for this room. ich changed the names of the acer computer inter Room402_01_acer and so on…

    So the new bluechip computers are now registered as Room402_01 and so on, but if i make a multicast session, they are not changing their computer names. They have all the same name of the image given to them.

    I have checked the Box ( “early hostname change” ) and also unchecked it, but there is no reaction to this.

    What also can be the problem?

    The FogClient ist installed.

  • Senior Developer

    @Hope1983 From the fog.log:

    25.11.2020 16:31 Middleware::Response Invalid security token
    

    That means the tokens used to encrypt the connection are not ok anymore. This happens over time or when changing hostnames for example. Go to the FOG web UI -> edit the settings of the host you got this log file from and click the big orange button named “Reset Encryption Data”. If you want to do this for several hosts in one fo you can create a group, put them all in and then go to the group settings and click “Reset Encryption Data” there.

    For the database you want to take a look at the credentials stored in /var/www/html/fog/lib/fog/config.class.php. Though I would imagine it’s user “root” with an empty password which was still used in FOG 1.5.5.


  • @sebastian-roth - No i didnt do a unicast deploy yet.

    -Here is the log file from 😄
    fog.log

    • No special characters, i dont know what i could do wrong in this room that this is happening

    i will test your suggestions in the coming days…

    one question… how can i connect with a external tool to the database? what user is there to connect to it. I want to use the MACs in another tool from me in c#
    That would be great

  • Senior Developer

    @Hope1983 That’s funny. I have just checked the early hostname change is working as we had another report on renaming and I wanted to make sure this is still working fine with Windows 10. And yes, it does in my test environment (FOG 1.5.9, Win 10, no fog-client installed)! I didn’t do a multicast deploy but the code for early hostname change is exactly the same for unicast and multicast.

    Did you do a unicast deploy as requested?

    Just to give you some more details. The early hostname change is done right after the deployment even before the host restarts the first time. We use Linux tools to modify the Windows registry on NTFS partitions to set the hostname “early” (even before a reboot).

    If that would not work you’d still have the fog-client in your case doing the hostname change when it’s up and running in Windows. If that does not work we need to take a look at the log file (C:\fog.log or C:\Program Files (x68)\FOG\fog.log). Upload the log file and post a link here.

    But in other rooms it works fine. It’s only this room where i changed the old acer computernames (r402_01 - r402_24 now r402_01acer etc )

    Do you have any special characters in those new names by any chance? It’s really interesting you see this happen only in that one room. So that means it does work in general.

    I think the namechanging in management does not work well probably?

    I am sure it does work in the latest version of FOG. Not exactly sure about 1.5.5 - years old. You might want to take a look at the database to find out. Let us know if you need help doing a DB query.

    How can i test if the “early hostname change” works fine? is there anywhere a “how to”?

    Well there is a way but it’s not easy. Debug deploy (unicast), step through it and when it’s done mount the Windows parttion and use reged to query the reg key “\CurrentControlSet\Control\ComputerName\ComputerName\ComputerName” in Windows/System32/config/SYSTEM

    The simple way would be to just boot up after a deploy and check the “HKLM\CurrentControlSet\Control\ComputerName\ComputerName\ComputerName”. But there is a slight chance something is happening on the first bootup resetting that registry key. So it’s not the best check you can do.

    A more simple pre-check to see if the setting is correct would be to schedule a debug deploy as well and when you get to the shell run echo $hostearly. This should reflect the setting of CHANGE_HOSTNAME_EARLY in the web UI.


  • @sebastian-roth oh sorry, i havent seen the answer since the holidays in bayern 🙂

    Ok, the image is a new one… the old image get another name, the new image is also not the same as the old one of the acers. Bitlocker is not activated.
    Version of Fog current 1.5.5 yeah i must update it, when i have got time for this 🙂

    But in other rooms it works fine. It’s only this room where i changed the old acer computernames (r402_01 - r402_24 now r402_01acer etc ) and then registerd the new one ( r402_01 etc ). I think the namechanging in management does not work well probably?

    How can i test if the “early hostname change” works fine? is there anywhere a “how to”?

  • Senior Developer

    @Hope1983 Which version of FOG do you use? BitLocker is probably not enabled on the computer you pulled the image from? Is the image you use still the same from when you used the Acer computers or did you change the image as well while switching to the new computers?

    May I ask you to do a unicast deployment to a single machine to see if the “early hostname change” works this way?

    Asking a lot of questions here but I want to make sure we get the full picture of this.

394
Online

8.1k
Users

15.0k
Topics

141.3k
Posts